ov5462 probe successful but reading registers is failing

cancel
Showing results for 
Search instead for 
Did you mean: 

ov5462 probe successful but reading registers is failing

313 Views
Contributor III

Hi Guys,

I connected ov5642 to my custom i.MX6Q Board.. Made the following settings in the device tree


ov564x: ov564x@3c {
compatible = "ovti,ov564x";
reg = <0x3c>;
pinctrl-names = "default";
pinctrl-0 = <&pinctrl_ipu1_2>;
clocks = <&clks 201>;
clock-names = "csi_mclk";
DOVDD-supply = <&vgen4_reg>;/* 1.8v */
AVDD-supply = <&vgen3_reg>; /* 2.8v, on rev C board is VGEN3,*/
DVDD-supply = <&vgen2_reg>; /* 1.5v*/
pwn-gpios = <&gpio1 19 1>; /* active low: SD1_DAT2 */
rst-gpios = <&gpio1 20 0>; /* active high: SD1_CLK */
csi_id = <0>;
mclk = <24000000>;
mclk_source = <0>;
ipu_id = <0>;
};

dmesg | grep ov5642 shows probe successful and camera is found but the driver is found, but it fails to apply the settings that is update the registers.

mxc_v4l2_master_attach: ipu0:/csi0 parallel attached ov5642:mxc_v4l2_cap0
ov5642 0-003c: created sysfs entry for reading regs
camera ov5642 is found
ov5642_write_reg:write reg error:reg=3003,val=0 ret=-110
ov5642_apply_settings, write reg 0x3003 failed
ov5642_write_reg:write reg error:reg=3103,val=93 ret=-5
ov5642_apply_settings, write reg 0x3103 failed

How to debug this scenario..

Labels (4)
Tags (1)
0 Kudos
5 Replies

16 Views
NXP TechSupport
NXP TechSupport

Hi Jamal

regarding ov5642 support please check comment Robby Cai Nov 11, 2015 12:28 AM on link
ov5642 is EOL, 3.14 BSP does not support ov5642 again.
About preview function in i.MX6SL. 

for errors one can check i2c1 with oscilloscope, use linux/arch/arm/boot/dts/imx6qdl-sabresd.dtsi

&i2c1 {.. ov564x: ov564x@3c {

imx6qdl-sabresd.dtsi\dts\boot\arm\arch - linux-imx - i.MX Linux kernel 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

16 Views
Contributor III

But I am using 3.10.53 linux version.. Is this not supported in 3.10.53 too.. In which version ov5642 is supported

0 Kudos

16 Views
NXP TechSupport
NXP TechSupport

seems it is supported in 3.10.53, check dts file :

&i2c1 {.. ov564x: ov564x@3c {

imx6qdl-sabresd.dtsi\dts\boot\arm\arch - linux-imx - i.MX Linux kernel 

Best regards
igor

0 Kudos

16 Views
Contributor III

I have the same settings.. It's able to detect the Chip Id but when writing/reading the registers later it is failing..

camera ov5642 is found
ov5642_write_reg:write reg error:reg=3810,val=c2 ret=-110
ov5642_apply_settings, write reg 0x3810 failed
ov5642_write_reg:write reg error:reg=3103,val=93 ret=-5
ov5642_apply_settings, write reg 0x3103 failed

ov564x: ov564x@3c {
compatible = "ovti,ov564x";
reg = <0x3c>;
pinctrl-names = "default";
pinctrl-0 = <&pinctrl_ipu1_2>;
clocks = <&clks 201>;
clock-names = "csi_mclk";
DOVDD-supply = <&vgen4_reg>;/* 1.8v */
AVDD-supply = <&vgen3_reg>; /* 2.8v, on rev C board is VGEN3,*/
DVDD-supply = <&vgen2_reg>; /* 1.5v*/
pwn-gpios = <&gpio1 19 1>; /* active low: SD1_DAT2 */
rst-gpios = <&gpio1 20 0>; /* active high: SD1_CLK */
csi_id = <0>;
mclk = <24000000>;
mclk_source = <0>;
ipu_id = <0>;
};

What do you think is the error..

0 Kudos

16 Views
NXP TechSupport
NXP TechSupport

suggest to check i2c signals with oscilloscope using driver sources in

/linux/drivers/media/video/mxc/capture/ov5642.c

Best regards
igor

0 Kudos