module "QtQuick.Controls" is not installed on imx6dl

cancel
Showing results for 
Search instead for 
Did you mean: 

module "QtQuick.Controls" is not installed on imx6dl

3,003 Views
nandishguruling
Contributor III

Hi All,

I am trying to build the qt/qml application using Qt creator IDE 5.9.1 and qmake version is 3.1  on Imx6dl sabreauto and Linux Kernel version 3.14.28, one can see the attached images, when open the new application for Qt Quick Controls2 Application it Supported Platforms: is only on Desktop, But i need the target machine also in other application say Qt Quick Application it Supported Platforms: Is bot Desktop and Target machine, for  Qt Quick Controls2 i tried installed possible libraries supported from forum, (qt - How to install QtQuick.Controls 1.4 on Ubuntu? - Stack Overflow ), but no luck still show the above error message, can any one help me how to resolve this issue,

Best Regards,

Nandish S.G

0 Kudos
4 Replies

490 Views
nandishguruling
Contributor III

Hi gusurambula,

Thank for your reply, Yes what you said  Qt Quick Controls 2 are available with Qt 5.7 or later is correct.

now i am try to build the new image i.e 4.9.11 BSP please let me see after building this i will update,

and i have one doubt suppose If i add the following things in  ../../../build/conf/local.conf file,

PACKAGECONFIG_append_pn-qtbase = " accessibility"

PACKAGECONFIG_append_pn-qtquickcontrols = " accessibility"

IMAGE_INSTALL_append=" \

qtconnectivity-qmlplugins \

    qtlocation \

    qtlocation-plugins \

    qtlocation-qmlplugins \

    qtlocation-examples \

    cinematicexperience \

    cairo pango fontconfig freetype pulseaudio dbus \

    alsa-lib alsa-tools alsa-state alsa-utils-alsaconf fsl-alsa-plugins \

    i2c-tools \

    qtquickcontrols-qmlplugins \

    qtquick1 \

    qtscript \

"

should i bitbake with image or toolchain, i.e  "bitbake fsl-image-qt5" or "bitbake meta-toolchain-qt5"

please suggest me,your help will be appreciable,

Thanks in advance,

Best Regards,

Nandish SG

0 Kudos

490 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Nandish S.G,

There may be a mismatch between the libraries from the meta-toolchain-qt5 and the ones needed for Qt Quick Controls2. The Qt5 toolchain and libraries available on the 3.14.28 BSP are for Qt 5.5 so they are not compatible. I’m not sure if there are workarounds but the NXP BSP only supports the included image and the creation of the toolchain as is.

Regards,

0 Kudos

490 Views
nandishguruling
Contributor III

Hi gusarambula,

Thanks for your quick reply, yes i am using the 3.14.28 BSP (image name " fsl-image-qt5 ")  and meta-toolchain-qt5 , you mean to say the 3.14.28 BSP are for Qt 5.5 are not compatible. then which one is compatible please suggest to me,

Thanks in Advance,

Best Regards

Nandish S.G

0 Kudos

490 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Nandish S.G,

On the description of the Qt Quick Controls 2 Application from the screenshot you shared it says that Qt Quick Controls 2 are available with Qt 5.7 or later. I haven’t used Qt Quick Controls and I’m not aware of it being supported on any NXP BSP but the 4.9.11 BSP has a Qt 5.8 image so perhaps the toolchain from that BSP may allow Qt Quick Controls 2.

Regards,

0 Kudos