ltib 'FSL gnome release package' build fails at gtk2 phase

cancel
Showing results for 
Search instead for 
Did you mean: 

ltib 'FSL gnome release package' build fails at gtk2 phase

794 Views
Robb1z
Contributor I

Hello...

I've been able to hack my way through this build so far with a little help from Google and this forum- but this one has me stumped...  somehow the Makefile is interpreting "no" as a command and there is no "no" that I've ever heard of.

I see that it is building "demos"- probably not needed- would anyone have a suggestion about possibly removing the demos section from the Makefile??

Output below:

Making all in demos
make[2]: Entering directory `/home/robb/ARM_board/L2.6.35_11.09.01_ER_source/ltib/rpm/BUILD/gtk+-2.14.3/demos'
no --raw --build-list        \
            apple_red  ./apple-red.png    \
                gnome_foot ./gnome-foot.png    \
        > test-inline-pixbufs.h                \
    || (rm -f test-inline-pixbufs.h && false)
/bin/bash: no: command not found
make[2]: *** [test-inline-pixbufs.h] Error 1
make[2]: Leaving directory `/home/robb/ARM_board/L2.6.35_11.09.01_ER_source/ltib/rpm/BUILD/gtk+-2.14.3/demos'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/robb/ARM_board/L2.6.35_11.09.01_ER_source/ltib/rpm/BUILD/gtk+-2.14.3'
make: *** [all] Error 2
error: Bad exit status from /home/robb/ARM_board/L2.6.35_11.09.01_ER_source/ltib/tmp/rpm-tmp.26722 (%build)


RPM build errors:
    Bad exit status from /home/robb/ARM_board/L2.6.35_11.09.01_ER_source/ltib/tmp/rpm-tmp.26722 (%build)
Build time for gtk2: 78 seconds

Failed building gtk2


f_buildrpms() returned an error, exiting
traceback:
 main:560


Started: Thu May  3 14:22:40 2012
Ended:   Thu May  3 14:23:58 2012
Elapsed: 78 seconds

These packages failed to build:
gtk2

Labels (1)
0 Kudos
2 Replies

362 Views
Robb1z
Contributor I

Great- that worked!  Thanks for the tip and also pointing me to imxdev.org.   Great site!

0 Kudos

362 Views
RandyKrakora
NXP Employee
NXP Employee

Look here at the first entry:

http://www.imxdev.org/wiki/index.php?title=FAQ

0 Kudos