imx8qxp Failed boot from net.

cancel
Showing results for 
Search instead for 
Did you mean: 

imx8qxp Failed boot from net.

Jump to solution
546 Views
nxf45220
NXP Employee
NXP Employee

Device : imx8qxp

Board  : imx8qxp-mek

Linux version : 4.14.78-ga(officially released by NXP, stable)

                        4.9.88-beta

1. Password needed when log in terminal.

pastedImage_1.png

2. During the bootup, Var directory in NFS was locked.

Hope you guys give some helpful suggestions.

Best,

Tags (1)
0 Kudos
1 Solution
234 Views
nxf45220
NXP Employee
NXP Employee

Hi community,

The issue was confirmed as the settings of server(as mentioned before), ttyLP0 is not supported to log in as root, you can replace /etc/securetty file with my attachment, hope it'll helpful!

pastedImage_1.png

Best

View solution in original post

0 Kudos
7 Replies
234 Views
art
NXP TechSupport
NXP TechSupport

Please follow exactly the NFS section of the attached document for the information on how to correctly boot the L4.14.78 BSP from NFS.

Best Regards,

Artur

0 Kudos
234 Views
nxf45220
NXP Employee
NXP Employee

Hi Artur,

Thank you for your replay.

My boot setting:

setenv serverip 10.xxx.xxx.74
setenv ipaddr 10.xxx.xxx.100
setenv ethaddr 00:01:02:03:04:05
setenv fdt_file fsl-imx8qxp-mek.dtb
setenv ip_dyn no
setenv netargs setenv bootargs console=${console},${baudrate} ${smp} ip=dhcp root=/dev/nfs nfsroot=${serverip}:${nfsroot},v3,tcp
setenv nfsroot /home/cqc/rootfs_4_imx8qxp_4.14.78
saveenv

User Guide setting:

setenv serverip 10.xxx.xxx.74
setenv ipaddr 10.xxx.xxx.100
setenv ethaddr 00:01:02:03:04:05
setenv image Image
setenv fdt_file fsl-imx8qxp-mek.dtb
setenv rootfsinfo 'setenv bootargs ${bootargs} root=/dev/nfs ip=dhcp nfsroot=${serverip}:/home/cqc/rootfs_4_imx8qxp_4.14.78,v3,tcp'
setenv bootcmd_net 'run rootfsinfo; tftp ${image}; tftp ${fdt_addr} ${fdt_file}; booti ${loadaddr} - ${fdt_addr}'
setenv bootcmd 'run bootcmd_net'

Actually, I did not see the difference between these two setting. With my boot setting, i.MX6 can bootup normally and log in with password 'root', can you give some other suggestion? Thanks in advance!

Best

0 Kudos
234 Views
art
NXP TechSupport
NXP TechSupport

Actually, the following definition in your boot settings looks strange for me:

nfsroot=${serverip}:${nfsroot},v3,tcp
setenv nfsroot /home/cqc/rootfs_4_imx8qxp_4.14.78

Try to place the 'setenv nfsroot /home/cqc/rootfs_4_imx8qxp_4.14.78' string upper before the 'nfsroot=${serverip}:${nfsroot},v3,tcp' one.

Artur

0 Kudos
234 Views
nxf45220
NXP Employee
NXP Employee

Hi Artur,

Thank you for your replay.

1. The problem you mentioned caused by the wrong format.

setenv rootfsinfo 'setenv bootargs ${bootargs} root=/dev/nfs ip=dhcp \  nfsroot=${serverip}:/home/cqc/rootfs_4_imx8qxp_4.14.78,v3,tcp'


setenv bootcmd_net 'run rootfsinfo; tftp ${image}; tftp ${fdt_addr} ${fdt_file}; booti ${loadaddr} - ${fdt_addr}'

2. Checked the uboot env difference between i.MX6 and i.MX8, they used different terminals type(see below two pics). 

Fig 1. i.MX6 terminal type

pastedImage_1.png

Fig 2. i.MX8 terminal type

pastedImage_2.png

Checked /etc/securetty file of my server, ttyLP0 is not supported to log in, I think this may the root cause for the log in failure,  can you give some suggestions? Much thanks!

Best

0 Kudos
235 Views
nxf45220
NXP Employee
NXP Employee

Hi community,

The issue was confirmed as the settings of server(as mentioned before), ttyLP0 is not supported to log in as root, you can replace /etc/securetty file with my attachment, hope it'll helpful!

pastedImage_1.png

Best

View solution in original post

0 Kudos
227 Views
nxf45220
NXP Employee
NXP Employee

Actually,

The log-in failure is caused by the authentication of file system, when I set the permission of file system to 777, the failure occurred, so do not change this when you setup the the NFS.

 

Best,

Daniel

0 Kudos
234 Views
art
NXP TechSupport
NXP TechSupport

Yes, this is the possible cause of the issue.

0 Kudos