imx8mn mclk configuration

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

imx8mn mclk configuration

Jump to solution
685 Views
link
Contributor III

Hi all:

    We use the imx8mn_evk to connect ov5640 camera and the DTS configuration is as follows.  We found that although IMX8MN_CLK_CLKO1 was configured for MCLK,  but no CLK signal was measured on IMX8MN_CLK_CLKO1.  CLK signal is actually output from GPIO1_14. 

    Why does this happen?  

 

ov5640_mipi_0: ov5640_mipi@3c {
		compatible = "ovti,ov5640";
		reg = <0x3c>;
		pinctrl-names = "default";
		pinctrl-0 = <&pinctrl_csi_pwn>, <&pinctrl_csi_rst>;
		clocks = <&clk IMX8MN_CLK_CLKO1>;
		clock-names = "xclk";
		assigned-clocks = <&clk IMX8MN_CLK_CLKO1>;
		assigned-clock-parents = <&clk IMX8MN_CLK_24M>;
		assigned-clock-rates = <24000000>;
		csi_id = <0>;
		powerdown-gpios = <&gpio1 7 GPIO_ACTIVE_HIGH>;
		reset-gpios = <&gpio1 6 GPIO_ACTIVE_LOW>;
		mclk = <24000000>;
		mclk_source = <0>;
		mipi_csi;
		status = "okay";
		port {
			ov5640_ep: endpoint {
				remote-endpoint = <&mipi1_sensor_ep>;
				data-lanes = <1 2>;
				clocks-lanes = <0>;
			};
		};
	};

 

    

Labels (1)
0 Kudos
Reply
1 Solution
679 Views
Zhiming_Liu
NXP TechSupport
NXP TechSupport

The CLKO1 connects to GPIO1_IO14

Qmiller_0-1649912144302.png

 

View solution in original post

0 Kudos
Reply
2 Replies
680 Views
Zhiming_Liu
NXP TechSupport
NXP TechSupport

The CLKO1 connects to GPIO1_IO14

Qmiller_0-1649912144302.png

 

0 Kudos
Reply
387 Views
araja
Contributor III
0 Kudos
Reply