imx8-mini-evk-sdk-build-doesnt-boot-kernel

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

imx8-mini-evk-sdk-build-doesnt-boot-kernel

828 Views
Flora1
Contributor I
Hello,
I am working on imx8 mini. evk board. I have tried to generate image by android build with the help of following document:
https://www.nxp.com/docs/en/user-guide/ANDROID_USERS_GUIDE.pdf

After following the above given steps for generating image, I have tried to flash. But after flashing kernel is getting stuck. Followed the steps for customise kernel as mention in document and tried to flash .

For cross check I have tried default image and it was flashed and boot successfully.
Attaching error logs in which my kernel is getting stuck:

0 Kudos
11 Replies

803 Views
Zhiming_Liu
NXP TechSupport
NXP TechSupport

Please share your build steps and log. Your build may be incomplete.

0 Kudos

801 Views
Flora1
Contributor I

source ~/imx-android-13.0.0_2.2.0/imx_android_setup.sh 

export MY_ANDROID=`pwd`

cd ${MY_ANDROID}

 source build/envsetup.sh

lunch evk_8mm-userdebug

  ./imx-make.sh -j4 2>&1 | tee build-log.txt


cross compiler : gcc-arm-9.2-2019.12-x86_64-aarch64-none-elf/bin/aarch64-none-elf-

this are the steps followed from the documents .

Attaching error logs

 

0 Kudos

790 Views
Zhiming_Liu
NXP TechSupport
NXP TechSupport

log.txt is boot log, not aosp build log.

0 Kudos

773 Views
Flora1
Contributor I
 
0 Kudos

752 Views
Zhiming_Liu
NXP TechSupport
NXP TechSupport

Checked the bulid log, no issue.

How did you flash your build image?

0 Kudos

748 Views
Flora1
Contributor I

1. Download the UUU binary file from GitHub as described before. Install UUU into a directory contained by the system environment variable of "PATH".
2. Make the board enter serial download mode.
For Rev. C2 boards, change the first four bits of board's sw1101 to 1000 (from 1-4 bit) to enter serial
download mode.
3. Power on the board. Use the USB cable on the board OTG port to connect your PC with the board.
4. Decompress release_package/android-13.0.0_2.2.0_image_8mnevk.tar.gz. The package
contains the image files

cd ~/android_build/out/target/product/evk_8mm 

After entering to this directory run this command for flash

./uuu_imx_android_flash.sh -f imx8mm -a -e  

0 Kudos

744 Views
Zhiming_Liu
NXP TechSupport
NXP TechSupport

I compiled same version, it can work.

 

U-Boot SPL 2023.04-00001-g9663b52880 (Dec 21 2023 - 13:33:05 +0900)
Can't find PMIC:PCA9450
DDRINFO: start DRAM init
DDRINFO: DRAM rate 3000MTS
DDRINFO:ddrphy calibration done
DDRINFO: ddrmix config done
SEC0:  RNG instantiated
Normal Boot
Trying to boot from MMC2
NOTICE:  Do not release JR0 to NS as it can be used by HAB
NOTICE:  BL31: v2.8(release):android-13.0.0_2.0.0-0-ge4b2dbfa5-dirty
NOTICE:  BL31: Built : 13:34:30, Dec 21 2023


U-Boot 2023.04-00001-g9663b52880 (Dec 21 2023 - 13:33:05 +0900)

CPU:   i.MX8MMQ rev1.0 at 1200MHz
CPU:   Commercial temperature grade (0C to 95C) at 35C
Reset cause: POR
Model: NXP i.MX8MM EVK board
DRAM:  2 GiB
optee optee: OP-TEE api uid mismatch
TCPC:  Vendor ID [0x1fc9], Product ID [0x5110], Addr [I2C1 0x52]
Power supply on USB2
TCPC:  Vendor ID [0x1fc9], Product ID [0x5110], Addr [I2C1 0x50]
Core:  220 devices, 35 uclasses, devicetree: separate
MMC:   FSL_SDHC: 1, FSL_SDHC: 2
Loading Environment from MMC... *** Warning - bad CRC, using default environment

[*]-Video Link 0adv7535_mipi2hdmi adv7535@3d: Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
mxs_video lcdif@32e00000: failed to get any video link display timings
probe video device failed, ret -22

        [0] lcdif@32e00000, video
        [1] mipi_dsi@32e10000, video_bridge
        [2] adv7535@3d, panel
adv7535_mipi2hdmi adv7535@3d: Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
mxs_video lcdif@32e00000: failed to get any video link display timings
probe video device failed, ret -22
In:    serial
Out:   serial
Err:   serial
SEC0:  RNG instantiated
flash target is MMC:2
Net:   eth0: ethernet@30be0000
Fastboot: Normal
Normal Boot
Hit any key to stop autoboot:  0
In boota get fastboot lock status error. Set lock status
Start userdata wipe process....
erase target is MMC:2
Erasing blocks 589824 to 598016 due to alignment
........ erased 4194304 bytes from 'misc'
erase target is MMC:2
Erasing blocks 598016 to 729088 due to alignment
........ erased 67108864 bytes from 'metadata'
Wipe userdata completed.
Unlock device for development...
Magic is incorrect.
Error validating A/B metadata from disk. Resetting and writing new A/B metadata to disk.
Writing A/B metadata to disk.
 verify OK, boot 'boot_a'
Kernel load addr 0x40480000 size 32971 KiB
kernel   @ 40480000 (34471936)
ramdisk  @ 44680000 (21205207)
fdt      @ 426e0400 (48872)
Device is unlocked, press power key to skip warning logo...
adv7535_mipi2hdmi adv7535@3d: Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
mxs_video lcdif@32e00000: failed to get any video link display timings
no video device found!
can't show unlock warning.
Moving Image from 0x40480000 to 0x40600000, end=426e0000
## Flattened Device Tree blob at 426e0400
   Booting using the fdt blob at 0x426e0400
Working FDT set to 426e0400
   Using Device Tree in place at 00000000426e0400, end 00000000426ef2e7
Working FDT set to 426e0400
adv7535_mipi2hdmi adv7535@3d: Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
mxs_video lcdif@32e00000: failed to get any video link display timings
probe video device failed, ret -22

Starting kernel ...

[    0.000000][    T0] Booting Linux on physical CPU 0x0000000000 [0x410fd034]
[    0.000000][    T0] Linux version 6.1.25-android14-11-maybe-dirty (build-user@build-host) (Android (10087095, +pgo, +bolt, +lto, -mlgo, based on r487747c) clang version 17.0.2 (https://android.googlesource.com/toolchain/llvm-project d9f89f4d16663d5012e5c09495f3b30ece3d2362), LLD 17.0.2) #1 SMP PREEMPT Thu Jan  1 00:00:00 UTC 1970
[    0.000000][    T0] Machine model: FSL i.MX8MM EVK board
[    0.000000][    T0] Stack Depot is disabled
[    0.000000][    T0] Enabling dynamic shadow call stack
[    0.000000][    T0] efi: UEFI not found.
[    0.000000][    T0] kvm [0]: Reserved 16 MiB at 0xbea00000
[    0.000000][    T0] Zone ranges:
[    0.000000][    T0]   DMA32    [mem 0x0000000040000000-0x00000000bfffffff]
[    0.000000][    T0]   Normal   empty
[    0.000000][    T0]   Device   empty
[    0.000000][    T0] Movable zone start for each node
[    0.000000][    T0] Early memory node ranges
[    0.000000][    T0]   node   0: [mem 0x0000000040000000-0x00000000bfffffff]
[    0.000000][    T0] Initmem setup node 0 [mem 0x0000000040000000-0x00000000bfffffff]
[    0.000000][    T0] cma: Reserved 800 MiB at 0x0000000086000000
[    0.000000][    T0] psci: probing for conduit method from DT.
[    0.000000][    T0] psci: PSCIv1.1 detected in firmware.
[    0.000000][    T0] psci: Using standard PSCI v0.2 function IDs
[    0.000000][    T0] psci: MIGRATE_INFO_TYPE not supported.
[    0.000000][    T0] psci: SMC Calling Convention v1.2
[    0.000000][    T0] Load bootconfig: 1000 bytes 63 nodes
[    0.000000][    T0] percpu: Embedded 30 pages/cpu s82152 r8192 d32536 u122880
[    0.000000][    T0] Detected VIPT I-cache on CPU0
[    0.000000][    T0] CPU features: SYS_ID_AA64MMFR1_EL1[11:8]: already set to 0
[    0.000000][    T0] CPU features: detected: GIC system register CPU interface
[    0.000000][    T0] CPU features: kernel page table isolation forced ON by KASLR
[    0.000000][    T0] CPU features: detected: Kernel page table isolation (KPTI)
[    0.000000][    T0] CPU features: detected: ARM erratum 845719
[    0.000000][    T0] alternatives: applying boot alternatives
[    0.000000][    T0] Built 1 zonelists, mobility grouping on.  Total pages: 516096
[    0.000000][    T0] Kernel command line: console=ttynull stack_depot_disable=on cgroup_disable=pressure kasan.page_alloc.sample=10 kasan.stacktrace=off kvm-arm.mode=protected bootconfig ioremap_guard console=ttymxc1,115200 earlycon=ec_imx6q,0x30890000,115200 init=/init firmware_class.path=/vendor/firmware loop.max_part=7 bootconfig transparent_hugepage=never moal.mod_para=wifi_mod_para_sd8987.conf cma=800M@0x400M-0xb80M fw_devlink.strict=0 bootconfig buildvariant=userdebug
0 Kudos

738 Views
Flora1
Contributor I

can you please share your build steps 

0 Kudos

735 Views
Zhiming_Liu
NXP TechSupport
NXP TechSupport

Same to you, you can try to clean out/ folder and rebuild it.

Zhiming_Liu_0-1703137362824.png

 

0 Kudos

603 Views
Flora1
Contributor I

which Ubuntu version have you used?

We are using Ubuntu  20.04.6 LTS so will it work on this host os version?

0 Kudos

592 Views
Zhiming_Liu
NXP TechSupport
NXP TechSupport

ubuntu20.04

0 Kudos