imx8: integrating meta-imx(ml & sdk) in a custom image for imx8mqevk target failing at rootfs

cancel
Showing results for 
Search instead for 
Did you mean: 

imx8: integrating meta-imx(ml & sdk) in a custom image for imx8mqevk target failing at rootfs

79 Views
Contributor III

Hi,

Thanks!

I am integrating meta-imx(meta-ml & meta-sdk) in a custom image for imx8mqevk. meta-imx source taken from L5.4.24 image. Image build failing at rootfs with "libpython3.7m.so.1.0". Custom image has python3.8 but pyarmnn needs python3.7 . Here are the logs:

ERROR: agl-demo-platform-1.0-r0 do_rootfs: Could not invoke dnf. Command '/home/vipulkumar/platform/AGL_Jellyfish/build/tmp/work/imx8mqevk-agl-linux/agl-demo-platform/1.0-r0/recipe-sysroot-native/usr/bin/dnf -v --rpmverbosity=info -y -c /home/vipulkumar/platform/AGL_Jellyfish/build/tmp/work/imx8mqevk-agl-linux/agl-demo-platform/1.0-r0/rootfs/etc/dnf/dnf.conf --setopt=reposdir=/home/vipulkumar/platform/AGL_Jellyfish/build/tmp/work/imx8mqevk-agl-linux/agl-demo-platform/1.0-r0/rootfs/etc/yum.repos.d --installroot=/home/vipulkumar/platform/AGL_Jellyfish/build/tmp/work/imx8mqevk-agl-linux/agl-demo-platform/1.0-r0/rootfs --setopt=logdir=/home/vipulkumar/platform/AGL_Jellyfish/build/tmp/work/imx8mqevk-agl-linux/agl-demo-platform/1.0-r0/temp --repofrompath=oe-repo,/home/vipulkumar/platform/AGL_Jellyfish/build/tmp/work/imx8mqevk-agl-linux/agl-demo-platform/1.0-r0/oe-rootfs-repo --nogpgcheck install kernel-modules libdrm-tests packagegroup-agl-core-devel packagegroup-agl-speech-services run-postinsts mc packagegroup-core-ssh-openssh packagegroup-agl-demo-platform packagegroup-core-tools-debug rpm dnf screen distro-build-manifest psplash packagegroup-core-tools-profile packagegroup-imx-ml' returned 1:
DNF version: 4.2.2
cachedir: /home/vipulkumar/platform/AGL_Jellyfish/build/tmp/work/imx8mqevk-agl-linux/agl-demo-platform/1.0-r0/rootfs/var/cache/dnf
Added oe-repo repo from /home/vipulkumar/platform/AGL_Jellyfish/build/tmp/work/imx8mqevk-agl-linux/agl-demo-platform/1.0-r0/oe-rootfs-repo
repo: using cache for: oe-repo
not found other for:
not found modules for:
not found deltainfo for:
not found updateinfo for:
oe-repo: using metadata from Thu 17 Sep 2020 11:58:44 AM UTC.
Last metadata expiration check: 0:00:01 ago on Thu 17 Sep 2020 11:59:11 AM UTC.
No module defaults found
--> Starting dependency resolution
--> Finished dependency resolution
Error:
Problem: package packagegroup-imx-ml-1.0-r0.noarch requires pyarmnn, but none of the providers can be installed
- conflicting requests
- nothing provides libpython3.7m.so.1.0()(64bit) needed by pyarmnn-19.08-r0.aarch64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

ERROR: Logfile of failure stored in: /home/vipulkumar/platform/AGL_Jellyfish/build/tmp/work/imx8mqevk-agl-linux/agl-demo-platform/1.0-r0/temp/log.do_rootfs.14609
ERROR: Task (/home/vipulkumar/platform/AGL_Jellyfish/meta-agl-demo/recipes-platform/images/agl-demo-platform.bb:do_rootfs) failed with exit code '1'

Any pointers on this will be helpful.

Host: Ubuntu 16.04

Target: imx8mq

Labels (1)
0 Kudos
2 Replies

48 Views
Contributor III

Hi,

Thanks!

Looks like the issue is because of python3.7, is there anyway to remove this specific dependency of pyarmnn as python 3.8(higher version) is already installed in image. Any suggestion on this?

0 Kudos

58 Views
NXP TechSupport
NXP TechSupport

Hello vsuneja63,

The imx-image-multimedia is contained in the meta-fsl-bsp-release/imx/meta-ml layer.

For better understanding please check the chapter 12 of your Linux User guide document that refers to NXP i.MX Machine learning.

 

Regards

 

0 Kudos