imx7d-Pico-Pi Alexa-AVS-demo / ERROR: avs-image-qt5-1.0-r0 do_image_ext4: Function failed: do_image_ext4

cancel
Showing results for 
Search instead for 
Did you mean: 

imx7d-Pico-Pi Alexa-AVS-demo / ERROR: avs-image-qt5-1.0-r0 do_image_ext4: Function failed: do_image_ext4

Jump to solution
1,293 Views
Contributor II

Hi All,

I was just compiling the image from this guide: Build Alexa SDK (AVS) image for i.mx7D PicoPi board (with Yocto Morty, Kernel4.9) 

Everything compiles fine but then i get this error message: ERROR: avs-image-qt5-1.0-r0 do_image_ext4: Function failed: do_image_ext4

I have tried recompiling several times on several different machines with no success and the same error. I also tried to reformat my drives which did not help either. One of my drives is an SSD 250GB and the other drive i used was a 1TB HDD.

Does anyone have any idea how to solve this issue? thank you.

Attached are the logs and the configuration files that were used.

Here is the error log:

WARNING: avs-image-qt5-1.0-r0 do_rootfs: [log_check] avs-image-qt5: found 1 warning message in the logfile:
[log_check] warning: Can't install perf-dev-4.9.11_1.0.0+g015d775-r9@imx7d_pico: Can't install perf-dev-4.9.11_1.0.0+g015d775-r9@imx7d_pico: no package provides perf = 4.9.11_4.9.11_1.0.0+g015d775.0+g015d775-r9

ERROR: avs-image-qt5-1.0-r0 do_image_ext4: Function failed: do_image_ext4 (log file is located at /data/yocto_dir/build/tmp/work/imx7d_pico-poky-linux-gnueabi/avs-image-qt5/1.0-r0/temp/log.do_image_ext4.31749)
ERROR: Logfile of failure stored in: /data/yocto_dir/build/tmp/work/imx7d_pico-poky-linux-gnueabi/avs-image-qt5/1.0-r0/temp/log.do_image_ext4.31749
Log data follows:
| DEBUG: Executing python function set_image_size
| DEBUG: Python function set_image_size finished
| DEBUG: Executing shell function do_image_ext4
| 0+0 records in
| 0+0 records out
| 0 bytes copied, 8.0355e-05 s, 0.0 kB/s
| mke2fs 1.43 (17-May-2016)
| Discarding device blocks: done
| Creating filesystem with 870400 4k blocks and 870480 inodes
| Filesystem UUID: d541daa8-fb8a-4b75-8e5a-c76fef2363eb
| Superblock backups stored on blocks:
| 32768, 98304, 163840, 229376, 294912, 819200
|
| Allocating group tables: done
| Writing inode tables: done
| Creating journal (16384 blocks): done
| Copying files into the device: __populate_fs: Could not allocate block in ext2 filesystem while writing file "pack-bfb37af8da50c6d4156d98438dedebf61a22afbe.pack"
| mkfs.ext4: Could not allocate block in ext2 filesystem while populating file system
| WARNING: exit code 1 from a shell command.
| ERROR: Function failed: do_image_ext4 (log file is located at /data/yocto_dir/build/tmp/work/imx7d_pico-poky-linux-gnueabi/avs-image-qt5/1.0-r0/temp/log.do_image_ext4.31749)
ERROR: Task (/data/yocto_dir/sources/meta-avs-demos/recipes-avs/images/avs-image-qt5.bb:do_image_ext4) failed with exit code '1'
NOTE: Tasks Summary: Attempted 8477 tasks of which 34 didn't need to be rerun and 1 failed.

Summary: 1 task failed:
/data/yocto_dir/sources/meta-avs-demos/recipes-avs/images/avs-image-qt5.bb:do_image_ext4
Summary: There were 37 WARNING messages shown.
Summary: There was 1 ERROR message shown, returning a non-zero exit code.

Labels (3)
1 Solution
91 Views
NXP TechSupport
NXP TechSupport

Hello,

The log message "Could not allocate block in ext2 filesystem while writing file ..." may mean,

that partition size is no enough. 

   You may try to increase it, using IMAGE_ROOTFS_SIZE parameter in "local.conf".

By default it is about 3.5G. 
 

Regards,

Yuri.

View solution in original post

4 Replies
91 Views
Contributor I

Hi,Cesar

I change local.conf

like this

#Rootfs size (Full eMMC - uboot/kernel partitions) = 3.5GB - 16MB
IMAGE_ROOTFS_SIZE = "5333152"
IMAGE_OVERHEAD_FACTOR = "1.0"

but also compile fail

Can help me where or how change?

Tks for all.

0 Kudos
92 Views
NXP TechSupport
NXP TechSupport

Hello,

The log message "Could not allocate block in ext2 filesystem while writing file ..." may mean,

that partition size is no enough. 

   You may try to increase it, using IMAGE_ROOTFS_SIZE parameter in "local.conf".

By default it is about 3.5G. 
 

Regards,

Yuri.

View solution in original post

91 Views
Contributor II

Yuri,

Thank you. I changed the IMAGE_ROOTFS_SIZE parameter in the "local.conf" file to 4.5GB and the image compiled with no problem.

Regards,

Cesar Hernandez

91 Views
NXP TechSupport
NXP TechSupport

Hello,

    Please verify requirements for host machine, using section 3 (Host Setup)

of "i.MX_Yocto_Project_User's_Guide.pdf".

  You may try to build at first regular image:

bitbake avs-image

https://www.nxp.com/webapp/Download?colCode=L4.9.11_1.0.0_LINUX_DOCS


Have a great day,
Yuri

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos