imx6ul can only boot from emmc with 1bit mode

cancel
Showing results for 
Search instead for 
Did you mean: 

imx6ul can only boot from emmc with 1bit mode

200 Views
Contributor II

Dears,

   we found that imx6ul can only boot from emmc with 1 bit mode, (Boot_cfg2[7~5]=000), neither 4bit nor 8bit would failed.

   it seems many guys met this issue before, but never found a solution yet, please kindly help to advise that.

such as:

https://community.nxp.com/message/908613?commentID=908613#comment-908613 

thank a lot.

0 Kudos
3 Replies

NXP TechSupport
NXP TechSupport

Hello,

You may create request / ticket to get some patches, that may help.

eMMC Fuses And Card did not respond to voltage select! I.MX6UL 

Support|NXP 

Regards,

Yuri.

0 Kudos

Contributor II

thank you very much.

0 Kudos

NXP TechSupport
NXP TechSupport

Hi Allon

general debug steps are provided on that link: attach the board with any JTAG debugger,

such as RV-ICE or Lauterbach and dump 0x907400,  you should see your IVT header

here if the eMMC access is ok. Also recommended to check signals with oscilloscope

and for problematic pins (big ringing, overshooting) change "PAD_SETTINGS" described

in Table 8-15. USDHC BooteFUSE Descriptions i.MX6UL Reference Manual (rev.1  4/2016)

http://www.nxp.com/docs/en/reference-manual/IMX6ULRM.pdf

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos