imx6q pcie link up failed

cancel
Showing results for 
Search instead for 
Did you mean: 

imx6q pcie link up failed

795 Views
minshi
Contributor I

hi

I want to debug the PCIE card, but it has been this error, what should I do?

iMX6 PCIe PCIe RC mode imx_pcie_pltfm_probe entering.

PCIE: imx_pcie_pltfm_probe start link up.

link up failed, DB_R0:0x005e3c00, DB_R1:0x08200000!

IMX PCIe port: link down!

Labels (2)
0 Kudos
2 Replies

230 Views
Yuri
NXP TechSupport
NXP TechSupport

Hello,

  Please look at the following

iMX6 PCIe PCIe RC mode imx_pcie_pltfm_probe entering.

Have a great day,
Yuri

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

230 Views
minshi
Contributor I

Hello,

I am using INTEL pc82573E(pcie to 1000Gbit ethernet) on our custom IMX6Q board based on SabreSD board. but it seems that could not recognise the devcie properly.

the kernel is Linux 3.0.35-imx,and  we choose board (mx6q_sabresd) on LTIB config.

here is what i have done:

add a star to:

System Type -> Freescale MXC Implementations -> PCI Express support

Bus support -> Message Signaled Interrupts (MSI and MSI-X)

Bus support -> PCI Express Support

Device Drivers -> Network Device support -> Ethernet (1000 Mbit)

Device Drivers -> Network Device support -> Ethernet (1000 Mbit) -> Realtek 8169 gigabit ethernet support

Device Drivers -> Network Device support -> Ethernet (1000 Mbit) -> Intel(R) PRO/1000 Gigabit Ethernet support

Device Drivers -> Network Device support -> Ethernet (1000 Mbit) -> Intel(R) PRO/1000 PCI-Express Gigabit Ethernet support

Device Drivers -> Network Device support -> Ethernet (1000 Mbit) -> IP1000 Gigabit Ethernet support

Device Drivers -> Network Device support -> Ethernet (1000 Mbit) -> Intel(R) 82575/82576 PCI-Express Gigabit Ethernet support

Device Drivers -> Network Device support -> Ethernet (1000 Mbit) -> Intel(R) 82576 Virtual Function Ethernet support

and remove the star from: make menuconfig -> Device Drivers -> Network Device support -> Ethernet (10 or 100Mb)

after compile the kernel i use MfgTool2 to load the uImage to the emmc on board.

But the question remains.

Hardware should be no problem, because my colleagues successfully before.

so what can i do?

Have a great day,

Pei

0 Kudos