imx6q keeps on rebooting, unable to boot into android

cancel
Showing results for 
Search instead for 
Did you mean: 

imx6q keeps on rebooting, unable to boot into android

2,253 Views
Jon1z
Contributor III

Hi,

     I just got an imx6q sabresd. I was able to compile the uboot, kernel and android using the default sabresd configurations and commands as detailed in the user guide. I am running the r13.3 version of the BSP. However, when I download the boot images and stuff into the eMMC of sabresd, I am not able to boot properly. the device keeps on rebooting again and again. I used MFGtool to download the image. Attached is the boot log of my device.

 

note: I always hear clicking noise whenever the board restarts, and whenever I restart it... is that normal?

Original Attachment has been moved to: imx6-compiled-downloadin-eMMC.TXT.zip

Labels (2)
0 Kudos
7 Replies

413 Views
Jon1z
Contributor III

Ok I found the culprit. The setting of GPIO_LED in 13.4 BSPs has been commented out. it is on board-mx6q_sabresd.c in arch/arm/ folder in the kernel.

The commented lines are the changes I did to 13.3 to make it boot up fine in my rev C1 board.

[code]

static struct gpio_led imx6q_gpio_leds[] = {

         GPIO_LED(SABRESD_CHARGE_NOW, "chg_now_led", 0, 1,

                 "charger-charging"),

/* For the latest B4 board, this GPIO_1 is connected to POR_B,

which will reset the whole board if this pin's level is changed,

so, for the latest board, we have to avoid using this pin as

GPIO

         GPIO_LED(SABRESD_CHARGE_DONE, "chg_done_led", 0, 1,

                         "charger-full"),

*/

};

[\code]

0 Kudos

413 Views
Jon1z
Contributor III

Ok, I just found out that android r13.3 BSP are for REV B of sabresd. Based on the schematics, there are A LOT of hardware changes from rev B3 to C1 (my colleague had a rev b3 board which the 13.3 images booted up just fine). So, heres a follow up question here: SabreSD SDP BSP compatibility

0 Kudos

413 Views
Jon1z
Contributor III

The files I used were boot.img, system.img, u-boot.bin, recovery.img, all of which are found in the out/product/target/sabresd directory...

The prebuilt images that came with the board booted fine..(sd boot and eMMC boot). however, my compiled images aren't. I also see huge file size differences between the pre-built images and my compiled images.. I'm missing something here but I don't know what anymore.. :|

0 Kudos

413 Views
yifangguo-b4310
NXP Employee
NXP Employee

Hi Jonathan :

From your log,   your u-boot set is not correct,   line 25 of your log: "Boot Device : SPI NOR" , the correct is "Boot Device: MMC" if you want boot from SD card or eMMC of board.

So, you can following chapters "Bootup --- Boot from MMC/SD " of user guide :

First,   switch your Boot switch pin of your board select boot your u-boot from SD card or eMMC of board.

Sec,  modify your uboot.  When  appear prompt

" Hit any key to stop autoboot:  3 "  , hit enter key and modify u-boot following user guide, and  modify correctly boot device of linux kernel.

0 Kudos

413 Views
Jon1z
Contributor III

Hi Thank you for your reply.

I changed the boot switch and I can now see that I am booting from MMC now.

I also made sure that the address for the kernel is correct (0x10800000). However I am still getting reboots.

I also want to let you know that the pre-built images of version 13.3 ALSO gets reboots, the same as the compiled ones.

however, the pre-built images from 13.4 runs fine...

anyone of you encountered this error when trying to run r13.3 to sabresd dev board?

I am downloading android r13.4 and linux kernel 3.0.35 right now to see the changes... also digging up the 13.4 patches for any clues... attached are the logs of the 13.4 prebuilt logs which runs fine and the 13.3 prebuilt, which restarts half way through...

0 Kudos

413 Views
yifangguo-b4310
NXP Employee
NXP Employee

Hi Jonathan :

     Have tested  r13.3 Android image released on my board ,  it's ok. Maybe some problem about code and your board compatibility.

r13.4 version is our latest  stable Android released for imx6 sabresd board, so you can debug your board using r13.4 please.

Have a good enjoy.


0 Kudos

413 Views
Jon1z
Contributor III

What board revision did you test the r13.3 pre-built android images on? My dev board is rev c1. Also, Is there a big difference between the SDP and SDB boards? mine is SDP.

will be trying out the compiled r13.4 in awhile. will also be diffing r13.3 and r13.4. hope I see something good.

Thanks for the reply.

0 Kudos