imx6q hdmi not display

cancel
Showing results for 
Search instead for 
Did you mean: 

imx6q hdmi not display

1,063 Views
田曙亮
Contributor I

I use MCIMX6Q-SDB board to test hdmi interface, use hdmi-vga adapter to connect pc display, but display nothing.

image is linux 3.0.35,supplied by freescale.

1.uboot bootargs is :

console=ttymxc0,115200 androidboot.console=ttymxc0 vmalloc=400M init=/init video=mxcfb0:dev=hdmi,1920x1080M@60 video=mxcfb1:off video=mxcfb2:off fbmem=28M

2.after system start, some parameters are :

cd /sys/devices/platform/mxc_hdmi

cat cable_state

plugin

cat edid

0(all is 0)

cat hdcp_enable

hdcp disable

cat rgb_out_enable

RGB out

cat fb_name

DISP3 BG

cd /sys/class/graphics/fb0/

cat modes

U:1280x720p-120

U:1280x720p-100

U:1920x1080p-30

U:1920x1080p-25

U:1920x1080p-24

U:1920x1080p-50

U:1440x576p-50

U:1440x576p-50

U:1440x288p-50

U:1440x288p-50

U:1280x720p-50

U:720x576p-50

U:720x576p-50

U:1920x1080p-60

U:1440x480p-60

U:1440x480p-60

U:1440x240p-60

U:1440x240p-60

U:1280x720p-60

U:720x480p-60

U:720x480p-60

U:640x480p-60

V:1280x1024p-60

V:1024x768p-60

V:640x480p-60

cat mode

U:1920x1080p-60

cat fsl_disp_dev_property

hdmi

3.plug in hdmi ,kernel log is

mxc_hdmi mxc_hdmi: Read EDID again

mxc_hdmi mxc_hdmi: No modes read from edid

mxc_hdmi mxc_hdmi: create default modelist

I want to know why imx6q hdmi can't display.

Labels (2)
0 Kudos
2 Replies

253 Views
mileswang
Contributor II

I met hdmi not display issue before. I added external power supply to hdmi-vga adapter to solve the problem.

0 Kudos

253 Views
田曙亮
Contributor I

thanks Miles。

I will buy one to test.

One more question:

I use hmdi cable to connect TV, android os can display normal.But linux os (rootfs.tar.bz2 or  ubuntu_oneiric_4.1.0.tgz) can't display.

I compare the uboot args, cable_state / modes / mode / edid parameters,those are the same.

After system boot , i find Xorg start failed. I download oneiric.tar again from freescale 。But , Xorg start failed again.

The log is :

root@linaro-ubuntu-desktop:~# export DISPLAY=:0.0

root@linaro-ubuntu-desktop:~# Xorg

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6

_XSERVTransOpen: transport open failed for inet6/linaro-ubuntu-desktop:0

_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X.Org X Server 1.10.4

Release Date: 2011-08-19

X Protocol Version 11, Revision 0

Build Operating System: Linux 2.6.35-24-omap armv7l Ubuntu

Current Operating System: Linux linaro-ubuntu-desktop 3.0.35-2666-gbdde708-gf3d259a-dirty #38 SMP PREEMPT Wed Sep 9 22:11:17 CST 2015 armv7l

Kernel command line: console=ttymxc0,115200 root=/dev/mmcblk0p1 rootwait vmalloc=400M video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24 video=mxcfb1:off video=mxcfb2:off fbmem=28M

Build Date: 19 October 2011  06:22:31AM

xorg-server 2:1.10.4-1ubuntu4.2 (For technical support please see http://www.ubuntu.com/support)

Current version of pixman: 0.22.2

        Before reporting problems, check http://wiki.x.org

        to make sure that you have the latest version.

Markers: (--) probed, (**) from config file, (==) default setting,

        (++) from command line, (!!) notice, (II) informational,

        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan  1 00:10:16 1970

(==) Using config file: "/etc/X11/xorg.conf"

Backtrace:

Segmentation fault at address 0xc

Caught signal 11 (Segmentation

==== system start log is :

modprobe: FATAL: Could not load /lib/modules/3.0.35-2666-gbdde708-gf3d259a-dirty/modules.dep: No such file or directory

error: unexpectedly disconnected from boot status daemon

* Starting Advanced Power Management daemon...                          [ OK ]

Last login: Thu Jan  1 00:02:09 UTC 1970 on tty1

speech-dispatcher disabled; edit /etc/default/speech-dispatcher

Checking for running unattended-upgrades:

/usr/lib/update-notifier/update-motd-updates-available: 52: cannot create /var/lib/update-notifier/updates-available: Directory nonexistent

run-parts: /etc/update-motd.d/90-updates-available exited with return code 2

/usr/lib/update-manager/release-upgrade-motd: 40: cannot create /var/lib/update-notifier/release-upgrade-available: Directory nonexistent

cat: /var/lib/update-notifier/fsck-at-reboot: No such file or directory

run-parts: /etc/update-motd.d/98-fsck-at-reboot exited with return code 1

root@linaro-ubuntu-desktop:~#  * Starting bluetooth                      [ OK ]

* PulseAudio configured for per-user sessions

saned disabled; edit /etc/default/saned

1 Jan 00:02:11 ntpdate[5251]: no servers can be used, exiting

Ps:uImage is compiled by myself and emmc boot.

0 Kudos