imx6q android system reboot issue on Android 4.3 after several seconds

cancel
Showing results for 
Search instead for 
Did you mean: 

imx6q android system reboot issue on Android 4.3 after several seconds

595 Views
pfsang
Contributor IV

hi,  ALL

      i encountered a problem about system reboot after about 20s.(i set android sleep time to 30min)

      my cpu (imx6q) works at 1Ghz.

      when i operate android (like play video, touch the panel), the system do not reboot automatically.

      but  when i do nothing , the system will reboot after about 20s . (i have tested several times).

      i also tried it on imx6DL, it has not the phenomenon .

      i have attached the log.

      by the way , i haven't ported pmic into the system. does it cause the reboot?

      do anyone give me suggest about how to debug it or what's the root cause?

 

 

Thanks

peter

Original Attachment has been moved to: after_20s_reboot.txt.zip

Original Attachment has been moved to: logcat_and_boot_log.txt.zip

Labels (5)
0 Kudos
5 Replies

53 Views
SergioSolis
NXP Employee
NXP Employee

Does it reboot even if you stop autoboot?, or is it only rebooting when you let android start?

0 Kudos

53 Views
pfsang
Contributor IV

hi, SerchMX

         >>  Does it reboot even if you stop autoboot?

             i don't stop autoboot and how to stop it?

         >>or is it only rebooting when you let android start?

             under linux , it do not reboot ,however under android , after the system start , if i do not any operation in about 20s , it will reboot .

0 Kudos

53 Views
SergioSolis
NXP Employee
NXP Employee

Is it a custom board you have? Have you ported the PMIC?, are you still having this issue?

0 Kudos

53 Views
saurabh206
Senior Contributor III

Hi,

Can you provide logcat detail?

And also check "developer options --> stay awake"  and "Display --> sleep time"

Saurabh

0 Kudos

53 Views
pfsang
Contributor IV

hi, Sauraph Patel

      Sorry to reply so late to you.

       i set "Display --> sleep time" to 30min and stay awake to disable

        and i added the logcat log

thanks

peter

0 Kudos