imx6q and lvds.

cancel
Showing results for 
Search instead for 
Did you mean: 

imx6q and lvds.

Jump to solution
6,470 Views
rumcajs666
Contributor II

Hi everyone,

 

I'm new in a community, on a forum and into imx6 linux development.Though i had experience with linux embedded on a ATNGW100.

 

Currently i;m working on a board with imx6q.

I have to run a lvds screen. It's connected with a imx6 through 2 channels 4 pairs each.

 

Unfortunately i can't run it.

Frankly, i don't know where the problem is.

Or is it a device tree configuration, or uboot command line settings.

 

I'm using community yocto bsp based on a sabresd machine.

What i did is disable a hdmi.

LVDS panel is a M240HTN01.2.

 

I've attached dmesg, bootargs and a device tree config files.

I wonder if someone could direct me where to find a knowledge to pass this issue?

 

Thanks!

Original Attachment has been moved to: files.bz2

Labels (3)
0 Kudos
1 Solution
595 Views
igorpadykov
NXP TechSupport
NXP TechSupport

HI Sebastian

first, one needs to add timings for that LCD, please check some examples

for struct fb_videomode

how to support WSVGA output in imx6sdq

http://boundarydevices.com/configuring-i-mx6-machines-different-screens-nitrogen6x-sabre-lite/

for lvds split mode settings one can check attached patch and link below

Re: i.MX6Q LVDS split mode outputs LVDS1 only

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
5 Replies
596 Views
igorpadykov
NXP TechSupport
NXP TechSupport

HI Sebastian

first, one needs to add timings for that LCD, please check some examples

for struct fb_videomode

how to support WSVGA output in imx6sdq

http://boundarydevices.com/configuring-i-mx6-machines-different-screens-nitrogen6x-sabre-lite/

for lvds split mode settings one can check attached patch and link below

Re: i.MX6Q LVDS split mode outputs LVDS1 only

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
595 Views
daniehoffman
Contributor I

Hi Igor

I just want to ask you, how do you apply this patch? 

Thank you

Kind regards

Danie

0 Kudos
595 Views
rumcajs666
Contributor II

Hi,

First. Thank you both for your time.

Igor's patch worked like a charm:)

Cheers!

Sebastian

0 Kudos
595 Views
csotoalonso
Contributor III

Hi Sebastian,

what do you mean when you say that you can't run it? I mean, is there any signal coming out or it does nothing at all? Maybe the problem is the same reported here

Just modifying clk-imx6q.c does the trick

Hope it helps

0 Kudos
595 Views
basinibharathi
Contributor II

Hi Igor,

I am a beginner for iMX6 and android. Currently, I am working with iMX6 quad sabre sd board with android OS. 

I want to implement/debug applications related to image/video/audio processing/LCD interface on iMX6.

Can you please suggest me what software/IDE I can use for coding.

Regards,

Bharathi

0 Kudos