imx6q + 4.19.35 + x11 + imx-image-full desktop does not display

cancel
Showing results for 
Search instead for 
Did you mean: 

imx6q + 4.19.35 + x11 + imx-image-full desktop does not display

490 Views
Contributor IV

Hi community:

Recently I transplanted the bsp of imx6q + 4.19.35, after starting hdmi displays the kernel logo and the yocto splash screen, it does not display the desktop, have you encountered it?

what I used:

DISTRO=fsl-imx-x11 MACHINE=imx6qsabresd source fsl-setup-release.sh -b build-x11-imx6qsabresd
bitbake imx-image-full

video args:

root@imx6qsabresd:~# cat /proc/cmdline
console=ttymxc0,115200 video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24 root=/dev/mmcblk3p2 rootwait rw

Thanks.

0 Kudos
7 Replies

72 Views
NXP TechSupport
NXP TechSupport

did you try the demo images? has the same result? pls try to use demo images to compare this first

Embedded Linux for i.MX Applications Processors | NXP 

0 Kudos

72 Views
Contributor IV

Hi Engineer Xie:
  I have already tried the "L4.19.35_1.1.0_images_MX6QPDLSOLOX.zip".
But because we are a customized circuit board, uboot and dtb have been replaced on the basis of this zip package.

0 Kudos

72 Views
NXP TechSupport
NXP TechSupport

I don't have imx6q board to test, I tested on imx6qp board, when board boot up, can  see the gray flowers on the hdmi in the end,  if play video, anything shows on the hdmi? or could you boot up weston ?

0 Kudos

72 Views
Contributor IV

Hi, What you means is should I try:

DISTRO=fsl-imx-wayland MACHINE=imx6qsabresd source fsl-setup-release.sh -b build-wayland-imx6qsabresd
bitbake imx-image-full

?

I will try it.

And could you pls take a photo of your imx6qp board bootup picture?

0 Kudos

72 Views
NXP TechSupport
NXP TechSupport

yes, you can try the wayland, x11 should have different boot up widows from wayland, in fact, you can see the log file from uart, if the boot up information is correct, you should boot up successfully

pastedImage_1.png

0 Kudos

72 Views
Contributor IV

Hi,

I tried the wayland file system and it still couldn't be displayed. In addition, there is a bug in the imx8 + wayland + qt system. The qt application icon started is random.
Your circuit board looks imx8mm platform.

0 Kudos

72 Views
NXP TechSupport
NXP TechSupport

yes, I used the imx8mm, because the boot up pic is the same one as imx6's

did you check the log file? boot up imx6q board successfully, pls send the log file, what difference between your customized board with nxp imx6q sabresd board?

0 Kudos