imx-ipuv3 imx-ipuv3.0: IPU Warning - IPU_INT_STAT_10 = 0x00000001

cancel
Showing results for 
Search instead for 
Did you mean: 

imx-ipuv3 imx-ipuv3.0: IPU Warning - IPU_INT_STAT_10 = 0x00000001

2,691 Views
stevekwon
Contributor II

Hi,

I'm using gstreamer to play RTSP stream and I seem to be getting this warning message on every frame.

I've had a look on "iMX6Q Reference Manual" and it says "SMFC0_FRM_LOST".  What does this exactly mean and how do I fix this?

Thanks in advance.

0 Kudos
3 Replies

210 Views
Yuri
NXP TechSupport
NXP TechSupport

It looks like FRaMe LOST situation occurs (I expect because IPU is overloaded).


Some information about it may be found in i.MX6 (Q) RM just before Table 37-36 (Error

Interrupts Summary) :
"The table below describes the error interrupts. The panic column indicates if this signal is

part of the logic generating the ipu_panic signal. The ipu_panic signal can be used for

indicating about errors that are result of data rate problems. Such problems may be a

result of the IPU running in slower clock then required by the use case. This signal can be

used in order to indicate the system that the IPU can't handle the desired data rate. In that

case the system may need to increase the clock to the IPU or simplify the use case."

210 Views
stevekwon
Contributor II

Thanks for the reply.  It's weird because I'm only receiving 1 stream of VGA @ 15FPS and I seem to be getting the error message on every frame but the video is showing up fine on the display.

I've had a look at the clock, it seems like IPU default clocks are set to 264MHz from the maximum of 266MHz?  I'm not changing the clock at all so is it safe to assume it's set to near max speed?

0 Kudos

210 Views
Yuri
NXP TechSupport
NXP TechSupport
0 Kudos