iMXUL pico som board config

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

iMXUL pico som board config

1,592 Views
maash
Contributor II

Hi.

I'm trying to use Technexion iMX6UL_emmc som with pico pi board. I'm using NXP supplied avs demo yocto recepi as base with technexion tn-imx_4.1.15_2.0.0_ga kernel branch. The som is 14x14 module with 512Mb ram and emmc. Picopi board is revision b1.

I've struggled to find any info regarding correct uboot configuration for this. I'm currently using picosom-imx6ul_defconfig and imx6ul-pico_pi.dtb as device tree.

I've noticed that there's no uEnv.txt for this bootloader and the memory size is 256 instead of 512. Also the core is at 398Mhz instead of 500Mhz.

The main issue is that the kernel boot stops as it tries to mount /dev/mmcblk0p2 as root. I've tried setting the root and mmcroot to /dev/mmcblk0p1, however the mmcroot cannot be changed (it changes back after boot even with saveenv).

U-Boot 2015.04tn-imx_v2015.04_4.1.15_1.0.0_ga+g6fd697c (Jul 05 2018 - 10:12:04)

CPU: Freescale i.MX6UL rev1.1 at 396 MHz
CPU: Temperature 52 C
Reset cause: POR
Board: PicoSOM i.mx6UL
Compatible baseboard: dwarf, hobbit, nymph, pi
I2C: ready
DRAM: 256 MiB
PMIC: PFUZE300 DEV_ID=0x30 REV_ID=0x11
MMC: FSL_SDHC: 0
Display: AT070TN94 (800x480)
Video: 800x480x24
In: serial
Out: serial
Err: serial
switch to partitions #0, OK
mmc0(part 0) is current device
Net: FEC1
Normal Boot
Hit any key to stop autoboot: 0
=> print
baseboard=pi_creoir_hat
baudrate=115200
boot_fdt=try
bootargs=console=ttymxc5,115200 cma=128M root=/dev/mmcblk0p1 rootwait rw
bootcmd=mmc dev ${mmcdev}; if mmc rescan; then if run loadbootenv; then echo Loaded environment from ${bootenv};run importbootenv;fi;if test -n $uenvcmi
bootcmd_mfg=bootz 0x87860000
bootdelay=1
bootenv=uEnv.txt
bootscript=echo Running bootscript from mmc ...; source
console=ttymxc5
default_baseboard=hobbit
detectmem=if test ${memdet} = 512MB; then setenv memsize cma=128M; else setenv memsize cma=96M; fi
ethact=FEC1
ethaddr=00:1f:7b:11:09:6a
ethprime=FEC
fdt_addr=0x83000000
fdt_high=0xffffffff
fdtfile=imx6ul-pico_hobbit.dtb
filesize=5bca50
image=zImage
importbootenv=echo Importing environment from mmc ...; env import -t -r $loadaddr $filesize
initrd_high=0xffffffff
loadaddr=0x80800000
loadbootenv=fatload mmc ${mmcdev} ${loadaddr} ${bootenv}
loadbootscript=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};
loadfdt=fatload mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${fdtfile}
loadimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${image}
memdet=512MB
memsize=cma=128M
mmcargs=setenv bootargs console=${console},${baudrate} ${memsize} root=${mmcroot}
mmcautodetect=yes
mmcboot=echo Booting from mmc ...; run detectmem; run mmcargs; echo baseboard is ${baseboard}; run setfdt; if test ${boot_fdt} = yes || test ${boot_fdt;
mmcdev=0
mmcpart=1
mmcroot=/dev/mmcblk0p2 rootwait rw
panel=AT070TN94
script=boot.scr
setfdt=setenv fdtfile ${som}_${baseboard}.dtb
som=imx6ul-pico
splashpos=m,m

Environment size: 2109/8188 bytes

Should I use different kernel branch? Or perhaps different uboot target?

Labels (3)
Tags (1)
0 Kudos
Reply
5 Replies

1,182 Views
igorpadykov
NXP Employee
NXP Employee

Hi Matti

ona can try steps described on

buildroot/board/technexion/imx6ulpico at master · buildroot/buildroot · GitHub 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
Reply

1,182 Views
maash
Contributor II

Thanks Igor.

In what kernel version/branch should the imx6ulpico_defconfig be found? There was no such info in the buildroot instructions.

I could not find this config in tn-imx_4.1.15_2.0.0_ga nor tn-imx_4.9.11_1.0.0_ga_test.

0 Kudos
Reply

1,182 Views
maash
Contributor II

Ok, I gave up on kernel search and got the u-boot sources from technexion.

GitHub - TechNexion/u-boot-edm: A modified u-boot bootloader 

I followed these instructions for u-boot build:

TechNexion BSP guide for kernel 4.1.15 - TechNexion

 

I build the suggested picosom-imx6ul_spl_defconfig and that generated the SPL and u-boot.img files.

I flashed the images after mounting the imx6ul with imx_usb:

sudo dd if=SPL of=/dev/sdb bs=1k seek=1 oflag=dsync

and

sudo dd if=u-boot.img of=/dev/sdb seek=2 bs=512

However this doesn't even start to boot. I assume that I tried to flash the u-boot.img to wrong offset? Any idea what the offset should be?

0 Kudos
Reply

1,182 Views
igorpadykov
NXP Employee
NXP Employee

this may be posted to vendor support of this software, as it is not nxp bsp :

Support - TechNexion 

Best regards
igor

0 Kudos
Reply

1,182 Views
maash
Contributor II

Ok. Thanks for the support!

0 Kudos
Reply