iMX8QM: LPSPI DMA not working

cancel
Showing results for 
Search instead for 
Did you mean: 

iMX8QM: LPSPI DMA not working

443 Views
philippe_schenk
Contributor IV

Hello

I noticed that on the new L5.4.24-2.1.0 release the DMA of LPSPI is not working and it is falling back to PIO:

[    1.533136] fsl_lpspi 5a020000.spi: dma setup error -19, use pio

How can I enable the DMA of LPSPI?

I already tried to set status of &edma2 node to "okay" which didn't work

Thanks for your help,
Philippe Schenker

0 Kudos
7 Replies

324 Views
philippe_schenk
Contributor IV

Hi @igorpadykov 

Thanks for your answer and sorry for my long response time. I reproduced this on a i.MX8QM MEK board:

root@imx8qmmek:~# dmesg | grep -i spi
[ 0.000000] GICv3: 512 SPIs implemented
[ 0.000000] GICv3: 0 Extended SPIs implemented
[ 1.533241] fsl_lpspi 5a020000.spi: dma setup error -19, use pio
root@imx8qmmek:~# dmesg > bootlog_L5.4-2.1.0.txt
root@imx8qmmek:~# cat /etc/os-release
ID="fsl-imx-xwayland"
NAME="NXP i.MX Release Distro"
VERSION="5.4-zeus (zeus)"
VERSION_ID="5.4-zeus"
PRETTY_NAME="NXP i.MX Release Distro 5.4-zeus (zeus)"

Please find the bootlog attached

0 Kudos

319 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi philippe_schenk

 

NXP has not "L5.4-2.1.0" linux version, probably you are using some third party kernel which

is not officially supported by NXP.

Please try to reproduce issue on NXP i.MX8QM MEK board with latest linux

from official NXP source.codeaurora.org/external/imx repository:

https://source.codeaurora.org/external/imx/linux-imx/tree/?h=imx_5.4.47_2.2.0

Documentation:

https://www.nxp.com/design/software/embedded-software/i-mx-software/embedded-linux-for-i-mx-applicat...

 

Best regards
igor

0 Kudos

280 Views
philippe_schenk
Contributor IV

Hi Igor

Thanks for your answer. I think you exactly know what I mean with "L5.4-2.1.0" I used the binary from NXP on the MEK.

In the meantime I know that this doesn't happen on 2.2.0 release so it got solved by that release.

Best Regards,
Philippe

0 Kudos

414 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Philippe

ona can try MLK-23865 commit

linux-imx - i.MX Linux kernel 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

384 Views
15962561745
Contributor II

 Hi  igorpadykov,

    How can I use spi3 as salve with DMA support at Android P2.3.5 ,kernel viersion is L4.14.98 .

I have try it ,but return error code is -12. When I select CONFIG_SPI_SALVE, error log is below:

spi_slave spi3: /lpspi@5a030000/spi3@0 is not called 'slave'
[spi_slave spi3: Failed to create SPI device for /lpspi@5a030000/spi3@0

 

0 Kudos

414 Views
philippe_schenk
Contributor IV

Hi Igor,

Thanks for your answer. The commit you mention is already in that branch I have the linux running on (L5.4.24-2.1.0) plus as I said I also tried to enable the &edma2 node without success.

That is why I think it may be something wrong here.

Best regards,
Philippe

0 Kudos

378 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Philippe

 

please try to reproduce issue on NXP i.MX8QM MEK board with linux from

source.codeaurora.org/external/imx/linux-imx repository
https://source.codeaurora.org/external/imx/linux-imx/tree/?h=imx_5.4.24_2.1.0

 

Best regards
igor

0 Kudos