iMX6q sabre board does not bring up the HDMI display

cancel
Showing results for 
Search instead for 
Did you mean: 

iMX6q sabre board does not bring up the HDMI display

236 Views
czur
Contributor III

Hi,

I am trying to get the HDMI 1280x800 display driven from a iMX6q sabre board. Initially I had got an error that the "HDMI is not ready" when booting up the linux kernel. I updated the u-boot parameters to set the video parameters as "video=mxcfb0:dev=hdmi,1280x800M@60,if=RGB32". After this the kernel did not throw any errors.

I saw that the video mode is still set wrongly to 

mode "640x480-60"
# D: 25.176 MHz, H: 31.469 kHz, V: 59.942 Hz
geometry 640 480 640 480 16
timings 39721 48 16 33 10 96 2
rgba 5/11,6/5,5/0,0/0
endmode

I tried changing the fb mode by "fbset -g 1280 800 1280 800 32", not he fb mode is set as 

mode "1280x800-21"
# D: 25.176 MHz, H: 17.483 kHz, V: 20.690 Hz
geometry 1280 800 1280 800 32
timings 39721 48 16 33 10 96 2
rgba 8/16,8/8,8/0,8/24
endmode

Although the display shows some output, the display is not occupying the entire screen and occupies only 1/4th of the screen on the top. picture attached. Do I need to modify the dts file to set the configuration?

I am not sure if thats the case as the Display worked fine with another sabre board with imx7.

Regards

Arun

2 Replies

63 Views
czur
Contributor III

Hi All,

The issue was with the X server settings. I added a new mode to xserver as below and display got rendered correctly.

xrandr --newmode "1280x800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync // using the command "cvt 1280 800" i got the mode parameters

xrandr --addmode "DISP3 BG" 1280x800_60.00

xrandr --output "DISP3 BG" --mode 1280x800_60.00

Regards

Arun

0 Kudos

63 Views
joanxie
NXP TechSupport
NXP TechSupport

yes, This resolution is not a standard CEA-861-D resolution, so the default HDMI driver doesn't support it.

You need to add this format