iMX6SL DDR3 boot issue

cancel
Showing results for 
Search instead for 
Did you mean: 

iMX6SL DDR3 boot issue

240 Views
PotatoChip
Contributor I

Dear community,

We are working on a project which running iMX6SL with DDR3. 

We used MX6SL_MMDC_DDR3_register_programming_aid_v0.7 for generating an init script for MT41K128M16JT-125-K. 

Then we ran calibration and stress test on ddr_stress_tester_v2.60 and it reported success.

Then, we applied the setting according to the init script to imximage.cfg in uboot source and built an uboot image. 

 

We find that the uboot image does not start by using mfgtool.  Mfgtool stopped at "Jumping to OS image" with this uboot image. 

We also tried to use dd command to save image to sd card directly. It also does not boot up.

 

I wonder if anyone can advise or help on it.

Best regards,

JJ

Labels (2)
0 Kudos
1 Reply

92 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi JJ

if you are trying to run MFG Tool on custom board, its firmware (located in

Profiles/Linux/OS Firmware/firmware) should be rebuild using command

$ bitbake fsl-image-mfgtool-initramfs

Please refer to attached Yocto Guide sect.6.2 Manufacturing Tool, MFGTool

image files are located in Profiles/Linux/OS Firmware/files - they also should be rebuild

and these files are programmed to boot devices, procedures (one of them is dd command)

are described in attached Linux Guide .

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos