iMX6Q interface with eMMC5.1

cancel
Showing results for 
Search instead for 
Did you mean: 

iMX6Q interface with eMMC5.1

465 Views
riteshpatel
Contributor II

Hi,

I am using iMX6Q on my custom board. I am planning to use eMMC 5.1. 

The eMMC is backward compatible to eMMC 4.5 & eMMC 5.0 versions only. I found iMX6Q only support MMC version upto max v4.41.

So just want to confirm, Can I interface iMX6Q with this eMMC and Boot my custom board from eMMC by doing any modifications?

Thanks,

Ritesh

Tags (3)
0 Kudos
3 Replies

136 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Ritesh

right, iMX6Q formally only support MMC version up to v4.41, this means support for

full functionality defined by that version of specification. However basic read/write

operations may be supported with more newer versions like eMMC 4.5 & eMMC 5.0 versions.

As eMMC 5.1 is compatible with these versions, seems it will work fine with it too.

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

136 Views
riteshpatel
Contributor II

Hi Igor,

Thanks for the Quick response.

That means the read/write operations can be possible between iMX6Q (supports up to ver4.4/4.41) and eMMC 5.1 with backward compatibility ver 4.5 & ver 5.0. But the booting the iMX6Q may not be possible with eMMC 5.1/5.0/4.5. Please correct if wrong.

0 Kudos

136 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Ritesh

 

right, it should support basic read/write operations and also booting, please look at :

https://community.nxp.com/docs/DOC-332187 

Best regards
igor

0 Kudos