iMX6 DL wired for 10/100 won't always connect to ethernet

cancel
Showing results for 
Search instead for 
Did you mean: 

iMX6 DL wired for 10/100 won't always connect to ethernet

391 Views
joshsorenson
Contributor I


We are using an i.MX6DL SOM from Variscite.  The SOM is mounted on a custom carrier we have designed which includes 10/100 ethernet.  The two 1000 pairs are used for a custom POE solution.  The iMX6 only connects to our building internet in some physical configurations.

It will connect successfully when wired directly to the building router.

It will connect successfully when wired to an IP phone with integrated switch, that is connected to a switch, connected to the router.

It will not connect when tied directly to a switch that is connected to the router.

I am not sure if this issue is related to the switches or the iMX6 hardware or software.  I have tried two different brands of switch, both have the same issue.

One other thing I have noticed, is that the indicator LEDs on the iMX6 jack and on the switch jack light up about 10 seconds after boot and continue to flash for about 5 seconds before stopping when its wired directly to a switch (where it doesn't work).  This leads me to believe the switch and iMX6 are communicating, but that they cannot resolve communication terms.

Any ideas?

Labels (1)
Tags (1)
3 Replies

123 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Josh

seems this may be caused by autonegotiation as reported on many forums:

https://supportforums.cisco.com/discussion/10326581/ethernet-auto-negotiation

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos

123 Views
joshsorenson
Contributor I

Igor - Thanks for your input. How do I setup my iMX6 device to hard code

10/100 duplex and disable auto negation?

Thanks

Josh

On Wed, Mar 16, 2016 at 8:29 PM, igorpadykov <admin@community.freescale.com>

0 Kudos

123 Views
igorpadykov
NXP TechSupport
NXP TechSupport

in i.MX6 ENET this can be done using SPEED register ENET_ECR,

autonegotiation is selected in PHY registers.

Best regards

igor

0 Kudos