i.mx6ul 编译QT的问题

cancel
Showing results for 
Search instead for 
Did you mean: 

i.mx6ul 编译QT的问题

521 Views
玉栋郭
Contributor III

各位好,

 我使用Yocto制作了i.mx6ul的SDK,(bitbake fsl-image-qt5 -c populate_sdk) ,我目前在使用SDK交叉编译QT5.7.0,

但是遇到报错:

arm-poky-linux-gnueabi-ld: unrecognized option '-Wl,--gc-sections'
arm-poky-linux-gnueabi-ld: use the --help option for usage information
make[3]: *** [../../../bin/uic] 错误 1
make[3]:正在离开目录 `/home/rd/imx6sdk/imx6ul/qt-everywhere-opensource-src-5.7.0/qtbase/src/tools/uic'
make[2]: *** [sub-uic-make_first] 错误 2
make[2]:正在离开目录 `/home/rd/imx6sdk/imx6ul/qt-everywhere-opensource-src-5.7.0/qtbase/src'
make[1]: *** [sub-src-make_first] 错误 2
make[1]:正在离开目录 `/home/rd/imx6sdk/imx6ul/qt-everywhere-opensource-src-5.7.0/qtbase'
make: *** [module-qtbase-make_first] 错误 2

请问该怎样解决?

Labels (3)
Tags (1)
0 Kudos
1 Reply

76 Views
jimmychan
NXP TechSupport
NXP TechSupport

For your information,

arm-linux-gnueabi-ld unrecognized option '-Wl,--gc-sections' - Stack Overflow 

in the "qtbase/mkspecs/common/linux.conf" , you may need to remove -Wl from the QMAKE_LFLAGS_GCSECTIONS variable:

@QMAKE_LFLAGS_GCSECTIONS = --gc-sections@

0 Kudos