[i.mx6q]ar6103 doesn't work on my platform

cancel
Showing results for 
Search instead for 
Did you mean: 

[i.mx6q]ar6103 doesn't work on my platform

435 Views
hao507
Contributor I

hardware:i.mx6q

software:android 4.2.2

dear all:

       i have a question,during debug my board,the wifi module ar6103 doesn't work on my platform,

i used sd3 slot ,and configure as follow:

-----------------------------------------------------------------------------------------------------------------------------

static const struct esdhc_platform_data mx6q_sabresd_sd3_data __initconst = {

  .always_present = 1,

  .keep_power_at_suspend = 1,

  .support_8bit = 1,

  .delay_line = 0,

  .runtime_pm = 1,

  .cd_type = ESDHC_CD_PERMANENT,

};

---------------------------------------------------------------------------------------------------------------------------------

then,the system startup log is:

---------------------------------------------------------------------------------------------------------------------------------

Compat-wireless backport release: patch-10-27-gd46416c-p

Backport based on  branching-msm-3.2.3-44-g65b285b

Calling CRDA to update world regulatory domain

World regulatory domain updated:

    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)

    (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

    (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)

    (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)

    (5140000 KHz - 5360000 KHz @ 40000 KHz), (N/A, 3000 mBm)

    (5460000 KHz - 5860000 KHz @ 40000 KHz), (N/A, 3000 mBm)

ath6kl_sdio_init_platform register success!

android_readwrite_file: ret=-2

android_readwrite_file: ret=-2

acc_open

acc_release

mmc1: queuing unknown CIS tuple 0x01 (3 bytes)

mmc1: queuing unknown CIS tuple 0x1a (5 bytes)

mmc1: queuing unknown CIS tuple 0x1b (8 bytes)

mmc1: queuing unknown CIS tuple 0x14 (0 bytes)

ath6kl: sdio new func 1 vendor 0x271 device 0x301 block 0x800/0x200

ath6kl: ath6kl_sdio_set_mbox_info end!

ath6kl: ath6kl_sdio_config end!

ath6kl: [ath6kl_core_init]:test1

ath6kl: hif power on

SDIO: Enabling device mmc1:0001:1...

[sdio_enable_func]:test1

[sdio_enable_func]:test2

ath6kl: Unable to enable sdio func: -62

ath6kl: ret=-62

ath6kl: Current ath6kl driver version is: 3.4.0.189

ath6kl: Failed to init ath6kl core

ath6kl_sdio: probe of mmc1:0001:1 failed with error -62

---------------------------------------------------------------------------------------------------------------------

i trace code and find in sdio.c(\hardware\imx\wlan\atheros\compat-wireless\drivers\net\wireless\ath\ath6kl)

the ath6kl_sdio_power_on function call ath6kl_sdio_power_on display error.

so i need help.

0 Kudos
3 Replies

89 Views
harekrishnaroy
Contributor III

Hi All,

Even i have similar problem.

Below is the log i am getting when doing insmod ath6kl_sdio.ko ath6kl_p2p=1

android_readwrite_file: ret=-2
android_readwrite_file: ret=-2
android_readwrite_file: ret=-2
ath6kl: temporary war to avoid sdio crc error
ath6kl: ar6003 hw 2.1.1 sdio fw 3.4.0.189.TABLET_DONGLE  api 4
IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
ath6kl: Current ath6kl driver version is: 3.4.0.189.

My Kernel version is 3,10.53

Regards,

Hare

0 Kudos

89 Views
alejandrolozan1
NXP Employee
NXP Employee

Hi,

Are you getting the same problem in one of our boards?

Is it possible to reproduce the issue in SABRE-SD board?

Regards,

Alejandro

0 Kudos

89 Views
sriramperiyasam
Contributor II

Hi,

I am also facing similar kind of problem, please let us know  if you have found the solution.

Thanks

Sriram

0 Kudos