i.mx6dl LVDS 1366x768 OpenGL Support

cancel
Showing results for 
Search instead for 
Did you mean: 

i.mx6dl LVDS 1366x768 OpenGL Support

679 Views
hichembenfekih
Contributor I

Hello,

I hope, this time I will get some support.

the following was my first post. since I did not received any help, I thought maybe I post the problem again :smileyhappy:.

I.MX6DL + LVDS Display 1366x782 + OpenGL ES + QT 

we have developed a custom Board based on i.mx6dl. the board is connected via LVDS to Display.

we have successfully tested the board with 1280x800 and 1920x1080 Displays.

the issue with the 1366x768 Display is that, I can not run the GPU-examples provided by NXP/Freescale

if I change the Display resolution to 1364x768, then the GPU-exmaples can be started, but a white bar is shown (on the left or on the right side) (maybe 8 pixel wide).

we are using a custom kernel build 3.14.52_1.0.0_ga-wandboard and Galcore Kernel module version 5.0.11.41671

(I had the same problem with our reference board "wandboard")

it will be very nice if I get some comments.

Thank you in advance. 

Hichem,

CANNON-Automata

Labels (1)
0 Kudos
5 Replies

92 Views
hichembenfekih
Contributor I

thank you BiyongSUN, when using the 1368X768 resolution, then I get a very bad white bar on the left side. I think this Display dependent. 

0 Kudos

92 Views
hichembenfekih
Contributor I

thank you for your reply. I just tested the 1360x768 resolution. I got the best results for now, better than 1364x768 and 1366x768 resolution. On the right side there is a black bar (maybe 6 pixel wide). I hope that our client can live with that :smileyhappy:

0 Kudos

92 Views
BiyongSUN
NXP Employee
NXP Employee

We have successful case using 1368X768 which is 8bit align.

0 Kudos

92 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Hichem

unfortunately 1366x768 resolution doesn't work with the IPU and GPU because that resolution
is not multiple of 8. One can try solution in a below post where the author recommends to set

width to 1360 due to IPU restrictions.
https://community.nxp.com/thread/272026

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

92 Views
wolnet
Contributor III

Dear Igor,

I used the resolution of 1368x768 an this works fine.

When I rotate the screen I miss the 2 pixels,

is there any option to set a "used size", so I can reduce the size back to 1366 and the rotate works well.

Kind regards

Wolfgang

0 Kudos