i.mx6 fsl-image-qt5

cancel
Showing results for 
Search instead for 
Did you mean: 

i.mx6 fsl-image-qt5

333 Views
玉栋郭
Contributor III

hi everyone

I'm trying  fsl-image-qt5 .   i want to mount nfs on my board . nfs  host is ubuntu 12.04 , i use commond 'mount -t nfs -o nolock 192.168.0.112:/home/vector/share /mnt"  buf i got an error "mount.nfs: an incorrect mount option was specified",what can i do about this?

Labels (2)
Tags (1)
0 Kudos
2 Replies

93 Views
fulinux
Contributor IV

Hi,

I have the same problem:

root@imx6qsabresd:/usr/lib# mount -t nfs -o nolock 192.168.0.10:/home /home/
mount.nfs: an incorrect mount option was specified

it is work well in BSP4.1.14_1.0.0.

And i can't use my bcmd wifi, when i use ifup wlan0.

0 Kudos

93 Views
jimmychan
NXP TechSupport
NXP TechSupport

you need to set the NFS rootfs in u-boot:

U-Boot > setenv rootfsinfo 'root=/dev/nfs ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp'

for more details, please read the i.MX_Linux_User's_Guide.pdf in BSP documentation. (Chapter 4.7.5 Running the Linux image from NFS)

0 Kudos