i.mx6, KSZ9021 fail to ping

cancel
Showing results for 
Search instead for 
Did you mean: 

i.mx6, KSZ9021 fail to ping

525 Views
Contributor I

Hello
I have a i.MX6 solo custom board and KSZ9021 phy
Succeed to communicate loopback to ethernet switch by phy i/f in mii level which use on u boot.
But, Occur the ping error.

I found the best of skew with the following command.

mii write 1 b 8104
mii write 1 c 1010 -> I tried these 2020 3030 ... f0f0

But, ping fails once every ten times.
What should I do?

Thanks

sing FEC device
host 192.168.11.1 is alive
=> ping 192.168.11.1
Using FEC device
host 192.168.11.1 is alive
=> ping 192.168.11.1
Using FEC device
host 192.168.11.1 is alive
=> ping 192.168.11.1
Using FEC device
host 192.168.11.1 is alive
=> ping 192.168.11.1
Using FEC device
host 192.168.11.1 is alive
=> ping 192.168.11.1
Using FEC device
host 192.168.11.1 is alive
=> ping 192.168.11.1
Using FEC device
error frame: 0x16f7a420 0x00000804
ping failed; host 192.168.11.1 is not alive
=> ping 192.168.11.1
Using FEC device
some error: 0x4c000000
error frame: 0x16f7a420 0x00000884
host 192.168.11.1 is alive
=> ping 192.168.11.1
Using FEC device
host 192.168.11.1 is alive
=> ping 192.168.11.1
Using FEC device
error frame: 0x16f7a420 0x00000804
ping failed; host 192.168.11.1 is not alive

Labels (4)
2 Replies

9 Views
NXP TechSupport
NXP TechSupport

Hi 周之 武田 

ksz9021 is used on sabrelite board and one can try boundary devices releases

GitHub - boundarydevices/u-boot-imx6: U-Boot branch to support the Freescale i.MX6 processor 

GitHub - boundarydevices/linux-imx6 at boundary-imx_4.1.15_1.0.0_ga 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

9 Views
Contributor I

Thanks for your reply.

I downloaded and checked the source code of the URL you mentioned.
But its source is older than that of my uboot-imx-rel_imx_4.1.15_2.0.0_ga.
Do I have a worth a try ?

I refer to following URL

https://community.nxp.com/thread/381119#comment-807539

In U-Boot, issue the following commands:
=> setenv disable_giga 1
=> saveenv
=> reset

it seems to be communicate at 100Mb

But Is it impossible  communicate of GigaEthernet ?

0 Kudos