i.MX8QXPMEK usage with MINISASTOCSI ov5640 camera

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX8QXPMEK usage with MINISASTOCSI ov5640 camera

Jump to solution
1,939 Views
nolan_zinn
Contributor III

I am trying to configure Linux on an i.MX8QXP MEK to interface with the MINISASTOCSI camera module, which implements the ov5640 camera.  It connects the MEK via a mini-sas cable to the CSI2 port.  I've read on other posts that you need fsl-imx8qxp-mek-mipi-ov5640.dtb to use this camera (See H.264 encoding with i.MX8QXPMEK and ov5640 on i.MX8QXP MEK ).  However, when I build with Yocto, the only available device tree blobs are fsl-imx8qxp-mek-ov5640.dtb and fsl-imx8qxp-mek-ov5640-rpmsg.dtb. 

I attempted to boot with both of these blobs to connect to my camera, but in both cases, during the boot sequence (which I was debugging over serial) it said:

[    2.553778] mxc-mipi-csi2 58227000.csi: mipi_csi2_probe
[    2.579501] mxc-parallel-csi 58261000.pcsi: mxc_parallel_csi_probe probe successfully
[    2.588903] ov5640_v3 5-003c: 5-003c supply DOVDD not found, using dummy regulator
[    2.596559] ov5640_v3 5-003c: 5-003c supply DVDD not found, using dummy regulator
[    2.604094] ov5640_v3 5-003c: 5-003c supply AVDD not found, using dummy regulator
[    2.664951] ov5640_read_reg:write reg error:reg=300a
[    2.669964] camera ov5640 is not found

which leads me to believe that the board is not running the mipi_csi2_probe because I didn't use the mipi-ov5640.dtb file.

Am I correct in assuming that my problem is that I do not have fsl-imx8qxp-mek-mipi-ov5640.dtb?  If so, how would I get it?

0 Kudos
1 Solution
1,184 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Nolan

one can test with "Image-fsl-imx8qxp-mek-ov5640.dtb" included in

Demo Image Linux Binary Demo Files - i.MX 8QXPlus MEK

change the DTB to Image-fsl-imx8qxp-mek-ov5640.dtb

setenv fdt_file ' Image-fsl-imx8qxp-mek-ov5640.dtb'.
By default, this camera will be allocated on /dev/video0, test it:
gst-launch1.0 v4l2src ! autovideosink

Best regards
igor

View solution in original post

0 Kudos
10 Replies
1,184 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Nolan

one can use

linux/arch/arm64/boot/dts/freescale/fsl-imx8qxp-mek-ov5640.dts

fsl-imx8qxp-mek-ov5640.dts\freescale\dts\boot\arm64\arch - linux-imx - i.MX Linux kernel 

and follow build steps described in sect.4.5.13 How to build imx-boot image by using imx-mkimage

attached Linux Guide. May be useful to check

Build Apalis iMX8/Colibri iMX8X Boot Image/Linux from Scratch 

For testing one can use Demo Images found on:

i.MX Software | NXP 

fsl-imx8qxp-mek-mipi-ov5640.dts can be found on

fsl-imx8qxp-mek-mipi-ov5640.dts\freescale\dts\boot\arm64\arch - linux-imx - i.MX Linux kernel 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
1,184 Views
nolan_zinn
Contributor III

Hi igorpadykov,

You said:

one can use

linux/arch/arm64/boot/dts/freescale/fsl-imx8qxp-mek-ov5640.dts

However, the problem is that this device tree activates the camera over the parallel csi connection, whereas my camera is connected over the mipi-csi2 connection.

I can see that the fsl-imx8qxp-mek-mipi-ov5640.dts file is from kernel version 4.14.78, and that it does not exist in kernel version 4.14.98 (which I'm using).  However, this file (fsl-imx8qxp-mek-ov5640.dtsi\freescale\dts\boot\arm64\arch - linux-imx - i.MX Linux kernel) is a .dtsi file, but is very similar to the fsl-imx8qxp-mek-mipi-ov5640.dts from 4.14.78.  I found out that this dtsi is included in the fsl-imx8qxp-mek-ov5640-rpmsg.dts file that I have been using.  However, despite the mipi_ov5640 connection being defined and included, the camera still will not function over the mipi-csi connection.  I'm stymied.

Thanks for your help,

Nolan Z

0 Kudos
1,185 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Nolan

one can test with "Image-fsl-imx8qxp-mek-ov5640.dtb" included in

Demo Image Linux Binary Demo Files - i.MX 8QXPlus MEK

change the DTB to Image-fsl-imx8qxp-mek-ov5640.dtb

setenv fdt_file ' Image-fsl-imx8qxp-mek-ov5640.dtb'.
By default, this camera will be allocated on /dev/video0, test it:
gst-launch1.0 v4l2src ! autovideosink

Best regards
igor

View solution in original post

0 Kudos
1,184 Views
nolan_zinn
Contributor III

Thanks Igor,

My problem was that I forgot to include fdt_file in my u-boot setenv instruction.  You're awesome!

Nolan Z

0 Kudos
1,184 Views
shriyanayak1992
Contributor II

hi nolan.zinn@bayer.comigorpadykov‌,

i used the Demo Image Linux Binary Demo Files - i.MX 8QXPlus MEK mentioned above but

i am facing the same issue.. when i am changing setenv fdt_file 'fsl-imx8qxp-mek-ov5640.dtb'.

this is the error i get

[   28.212499] imx-drm display-subsystem: bound imx-drm-dpu-bliteng.2 (ops dpu_bliteng_ops)
[   28.220739] imx-drm display-subsystem: bound imx-dpu-crtc.0 (ops dpu_crtc_ops)
[   28.228079] imx-drm display-subsystem: bound imx-dpu-crtc.1 (ops dpu_crtc_ops)
[   28.235468] imx-drm display-subsystem: failed to bind ldb@562210e0 (ops imx_ldb_ops): -517
[   28.243941] imx-drm display-subsystem: master bind failed: -517
[   28.272630] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[   28.279303] [drm] No driver support for vblank timestamp query.

fixed it by refering this document How to use non-rpmsg.dtbs on i.MX 8QXP after which i end up having the same error

[    2.664951] ov5640_read_reg:write reg error:reg=300a.

and when i use fsl-imx8qxp-mek-ov5640-rpmsg.dtb'  i get this error 

[    2.664951] ov5640_read_reg:write reg error:reg=300a.

Regards,
Sriraksha

0 Kudos
218 Views
Michael_Du
Contributor I

Hi Sriraksha

    Did you fix this issue? I met the same issue and could not get what to cause this. 

0 Kudos
1,005 Views
shabna_m
Contributor III

@igorpadykov 

I am using imx8qm mek.

I have flashed prebuilt images (L4.14.98_2.0.0_ga_images_MX8QMMEK.zip) from NXP.

Connected the OV5640 camera module to the board.

Done setenv fdt_file 'fsl-imx8qm-mek-ov5640.dtb'.

Booting the board gives following error in the boot log.

[ 3.231883] mxc-mipi-csi2 58227000.csi: mipi_csi2_probe
[ 3.267333] mxc-mipi-csi2 58247000.csi: mipi_csi2_probe
[ 3.292096] ov5640_mipi_v3 8-003c: 8-003c supply DOVDD not found, using dummy regulator
[ 3.300173] ov5640_mipi_v3 8-003c: 8-003c supply DVDD not found, using dummy regulator
[ 3.308123] ov5640_mipi_v3 8-003c: 8-003c supply AVDD not found, using dummy regulator
[ 3.462429] usb 1-1: new full-speed USB device number 2 using ci_hdrc
[ 4.354419] ov5640_mipi_v3 8-003c: Read reg error: reg=300a
[ 4.359996] camera ov5640 is not found

Could you please help me on this?

 

0 Kudos
899 Views
yibhan
Contributor III

Hi shabna_m,

 

Did you solve your issue about MINISASTOCSI ov5640 camera in imx8qmmek ?

I have same issue.

 

0 Kudos
891 Views
shabna_m
Contributor III

@yibhan

I have unplugged the cameras and plugged it again properly solved the issue.

852 Views
zoosagy
Contributor I

Thank you  shabna_m !

I had the same issue and can't solved it.

Look at your answer and plug in the connector clearly(strongly) and it works.

0 Kudos