i.MX8QM Yocto camera issue

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX8QM Yocto camera issue

Jump to solution
1,138 Views
xu_ji1
Contributor V

Hello,

I use 8QM Yocto and test camera preview,when I send command:

GSTL v4l2src device=/dev/video1 ! 'video/x-raw,
format=(string)UYVY,width=640,height=480,framerate=(fraction)30/1'
! autovideosink

the console return -sh: GSTL: command not found

how to fixed this problem?

Thanks

0 Kudos
1 Solution
842 Views
xu_ji1
Contributor V

When I used mx8_v4l2_cap_drm.out case,camera can work normal

View solution in original post

0 Kudos
11 Replies
843 Views
xu_ji1
Contributor V

When I used mx8_v4l2_cap_drm.out case,camera can work normal

0 Kudos
724 Views
RameshChandrakasan
Contributor III

Dear Xu Ji

MY board : I.MX8QM - Freescale MEK

Linux Version:

repo init -u https://source.codeaurora.org/external/imx/imx-manifest -b imx-linux-sumo -m imx-4.14.98-2.3.0.xml

DTB: fsl-imx8qm-mek-hdmi.dtb

What i am doing :

/unit_tests/V4L2/mx8_v4l2_cap_drm.out -cam 1 -of
/unit_tests/V4L2/mx8_v4l2_cap_drm.out -cam 1
/unit_tests/V4L2/mx8_v4l2_cap_drm.out -cam 1 -m 0 -fr 30

Problem:

I am not getting any picture on Display

(debug_log attached)

Pls help

0 Kudos
723 Views
RameshChandrakasan
Contributor III

Dear Xu Ji

I do want to run using gstreamer.

I want to run mx8_v4l2_cap_drm.out

Regards

Ramesh

0 Kudos
845 Views
ruthjoan481
Contributor I

Hi, you are using an IMX8 QM board with imx-yocto-L4.14.78_1.0.0_ga release, right? I am trying to boot an image on my IMX8qmlpddr4arm2 board with sumo but this image can't boot. I have reproduced the steps on the yocto manual but I do not know why it fails Did you have this kind of problems?

Sorry for this out of topic question but I have not found tellthebell informations that could help me yet.

Thank you, and sorry for bad english.

0 Kudos
845 Views
xu_ji1
Contributor V

Hi,

what is your error log?

Thanks

0 Kudos
845 Views
joanxie
NXP TechSupport
NXP TechSupport

if you don't define GSTL,  try to use gst-launch-1.0 to instead of GSTL

0 Kudos
845 Views
xu_ji1
Contributor V

hello,

When I changed to gst-launch-1.0 below error:

Setting pipeline to PAUSED ...
Caught SIGSEGV
exec gdb failed: No such file or directory
Spinning. Please run 'gdb gst-launch-1.0 4092' to continue debugging, Ctrl-C to quit, or Ctrl-\ to dump core.

Thanks

0 Kudos
846 Views
joanxie
NXP TechSupport
NXP TechSupport

pls run "gdb gst-launch-1.0 4092", then debug the issue, if you just want to test camera, you can use unit test, under /unit_test/V4L2, then use the mxc_v4l2_overlay.out, then pls ensure you connect hdmi to your board already

0 Kudos
847 Views
xu_ji1
Contributor V

hello,

I used the unit test mxc_v4l2_overlay.out,and log shows:


---- Running < ./mxc_v4l2_overlay.out > test ----

g_display_width = 240, g_display_height = 320
g_display_top = 0, g_display_left = 0
sensor chip is imx8_max9286_mipi_0
VIDIOC_S_OUTPUT failed

what is the problem?

0 Kudos
844 Views
joanxie
NXP TechSupport
NXP TechSupport

if you use 9286, you can refer to the document as below:

https://www.nxp.com/docs/en/user-guide/SVAUG.pdf 

0 Kudos
844 Views
xu_ji1
Contributor V

yes,I only want to test camera,please give guide about test camera that I used SAS cable with MAX9286 connect four OV10635

Thanks

0 Kudos