i.MX8MQ USB0 (OTG) Boot Up Process Hang

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX8MQ USB0 (OTG) Boot Up Process Hang

386 Views
Contributor III

Hi Experts,

We have a customer meets USB issue on i.MX8MQ.
H/W: Customer's i.MX8MQ board
S/W: Android P9.0.0_2.0.0

Customer's design on USB0 (OTG) is not using Type-C, only connect to mini USB_TYPE_AB connector. The typec_ptn5100 settings is also take off on Device Tree.

Customer use USB0 OTG + MFGTool to flash on-board eMMC in Serial Download Mode is OK and correctly.

However, boot up process hangs while initial USB, the log is as attachment. But if disable USB0 on Device Tree, boot up process is OK and be able to access Android system.

I try to use my company's i.MX8MQ board or NXP i.MX8MQ EVK to reproduce the costomer's issue but no luck. USB0 initial process is fine on these two boards. Even I take off the components of USB0 design, leave USB0 pins as floating, the issue is only happens on customer's board. USB initial process is OK on my company's i.MX8MQ board while UBS0 pins is floating.

I'm stuck. Any suggestion for this issue? Is there any verification I can do?

p.s. customer use Yocto L4.14.98_2.0.0 to verify this issue on their board, got the same result.

Thanks and Regards,
Wayne Kuo

Tags (3)
0 Kudos
1 Reply

5 Views
NXP TechSupport
NXP TechSupport

Hi Wayne,

Open fsl-imx8mq.dtsi, and find usb_dwc3_0 node, and add "maximum-speed" property, like below:

&usb_dwc3_0 {

    status = "okay";

    extcon = <&typec_ptn5100>;

    dr_mode = "otg";

    hnp-disable;

    srp-disable;

    adp-disable;

    maximum-speed;

};


Then try.

In addition, you have submitted the same question to our system, let me discuss it there.

Have a nice day!

BR,

Weidong

0 Kudos