i.MX8M Android9 / 8.1 Wifi connection results in failure with GUI - (with the presence of active Ethernet connection)

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX8M Android9 / 8.1 Wifi connection results in failure with GUI - (with the presence of active Ethernet connection)

322 Views
gangadharan_vem
Contributor I

Hi All,

I am trying to use wifi - station mode through "Wifi Settings - Default GUI" with imx8mqevk running AndroidP9.

Connection to an AP results in failure if it has a working Ethernet connection . Profile gets selected, saved but the connection is not complete. Same response with usage after toggling wifi ON/OFF / retries.

By default, i had an Ethernet cable attached, it was UP and running, once the Ethernet cable is detached, i could use wifi and it is able to connect an AP successfully.

It looks like, unless the Ethernet is detached, wifi GUI doesn't initiate a connection.

Results are same with both the Android 8.1 / Android 9 NXP provided demo images.

Target Platform: i.MX8MQ-EVK

OS: Android O8.1 / Android P9 NXP provided BSP.

Issue: Wifi doesn't connect when Ethernet connection is UP and running. 

Any Information / pointers to resolve this issue will be very helpful.

Thanks in Advance,

Ganga Vemula.

0 Kudos
2 Replies

77 Views
diegoadrian
NXP Employee
NXP Employee

Hello,

Which revision of board do you have?

This is because I tested on my board and I could have an internet connection through without connecting the ethernet cable from the beginning. I used the Android 9 prebuild image. 

Best regards,

Diego.

0 Kudos

77 Views
gangadharan_vem
Contributor I

Hi Diego,

Thanks for the response. I have used 700-29615 RevA (imx8mqevk).

I could also use wifi without ethernet cable, but please note that my concern is wifi connection from GUI fails if ethernet connection preexists and active.

Ethernet Connected(Already UP and runnig with ip) + wifi connection from GUI  = Wifi Fails to connect with an access point.

Best Regards,

Ganga

0 Kudos