i.MX8-MEVK UART Input No Response

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX8-MEVK UART Input No Response

Jump to solution
185 Views
Contributor I

Hi experts,

 

I was recently working with i.MX 8M Evaluation Kit, while the board's debug UART ports get very slow response to the keyboard inputs.

For device, I tried:

1) the preloaded Android image with EMMC boot;

2) a self-built fsl-image-validation-imx image with SD boot.

For the host side, I tried both mac OS and ubuntu-16.04 with minicom.

Right now, both images can boot up, and the UART ports can print the system logs correctly.

However, if I want to interact with the UART port like typing any command in the UART port

evk_8mq:/ $

, the UART becomes very slow, and even no response to my input after a while.

 

I'm wondering if anyone runs into this scenario, or knows what would be the possible reason?

Thank you in advance.

 

Simon

0 Kudos
1 Solution
30 Views
NXP TechSupport
NXP TechSupport

Hi Simon

one can try Demo Images from

i.MX Software | NXP 

Getting Started with the i.MX 8M Evaluation Kit|NXP 

and try to update UART-USB  cp2105 drivers which EVK uses

USB to UART Bridge VCP Drivers - Silicon Labs

Schematics
Design Files for the i.MX 8M Evaluation Kit (EVK)(REV 0)
i.MX 8M Evaluation Kit | NXP 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
2 Replies
31 Views
NXP TechSupport
NXP TechSupport

Hi Simon

one can try Demo Images from

i.MX Software | NXP 

Getting Started with the i.MX 8M Evaluation Kit|NXP 

and try to update UART-USB  cp2105 drivers which EVK uses

USB to UART Bridge VCP Drivers - Silicon Labs

Schematics
Design Files for the i.MX 8M Evaluation Kit (EVK)(REV 0)
i.MX 8M Evaluation Kit | NXP 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
30 Views
Contributor I

Thanks for the answer. After I update several things the UART works fine so I guess it should be a driver issue.

0 Kudos