i.MX6solo android 4.4.3 HDMI not working in i2c4

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX6solo android 4.4.3 HDMI not working in i2c4

336 Views
Senior Contributor II

Hi all,

HDMI bootargs i given properly and also cross checked with evk. In freescale android source have hdmi in i2c2. But our custom board hdmi configured to i2c4. so i commented hdmi initialization in i2c2(imx6qdl-sabresd.dtsi) and added in i2c4(imx6dl-sabresd.dts). Below lines i added.

&i2c4 {

        clock-frequency = <100000>;

        pinctrl-names = "default";

        pinctrl-0 = <&pinctrl_i2c4_2>;

        status = "okay";

        hdmi: edid@50 {

                compatible = "fsl,imx6-hdmi-i2c";

                reg = <0x50>;

        };

};

Other than the above nothing i add in kernel and uboot also i didn't touched. But HDMI not working ??

Regards,

Aravinth

0 Kudos
3 Replies

40 Views
NXP TechSupport
NXP TechSupport

Hi Aravinth

what is about pinctrl_i2c4_2, it should be defined somewhere like:

    pinctrl_i2c4_2: i2c4grp-2 {
   fsl,pins = <
   MX6SX_PAD_SD3_DATA1__I2C4_SDA       0x4001b8b1
   MX6SX_PAD_SD3_DATA0__I2C4_SCL       0x4001b8b1
   >;

had you checked signals with oscilloscope ?

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos

40 Views
Senior Contributor II

Hi igorpadykov

i configured like,

i2c4 {

                pinctrl_i2c4_2: i2c4grp-1 {

                        fsl,pins = <

                                MX6QDL_PAD_ENET_TX_EN__I2C4_SCL         0x4001b8b1

                                MX6QDL_PAD_ENET_TXD1__I2C4_SDA          0x4001b8b1

                      >;

                };

   I2C is probing. But hdmi data not getting.

Regards,

Aravinth

0 Kudos

40 Views
NXP TechSupport
NXP TechSupport

Hi Aravinth

seems one can debug it using sect15.2.3 Display Device Registration

and Initialization attached Linux Manual.

~igor

0 Kudos