i.MX6UL custumized board Booting issue on SD1 cahnnel

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX6UL custumized board Booting issue on SD1 cahnnel

2,614 Views
PramodKumar
Contributor IV

Hi,

We have designed our board using i.MX6UL processor with reference of i.MX6UL EVK only difference is Botting media SD card is on SD1 channel while in EVK booting channel is SD2.

the booting msg of baords as given below

U-Boot 2015.04imx_v2015.04_4.1.15_1.2.0_ga+gede7538 (Apr 22 2017 - 15:12:20)

CPU:   Freescale i.MX6UL rev1.2 at 396 MHz
CPU:   Temperature 31 C
Reset cause: POR
Board: MX6UL 14x14 EVK
I2C:   ready
DRAM:  512 MiB
force_idle_bus: sda=0 scl=0 sda.gp=0x1d scl.gp=0x1c
MMC:   FSL_SDHC: 0, FSL_SDHC: 1
Using default environment

In:    serial                                                                   
Out:   serial                                                                   
Err:   serial                                                                   
switch to partitions #0, OK                                                     
mmc0 is current device                                                          
Net:   FEC0                                                                     
Error: FEC0 address not set.                                                    
                                                                                
Normal Boot                                                                     
Hit any key to stop autoboot:  0                                                
switch to partitions #0, OK                                                     
mmc0 is current device                                                          
switch to partitions #0, OK                                                     
mmc0 is current device                                                          
** No partition table - mmc 0 **                                                
** No partition table - mmc 0 **                                                
Booting from net ...                                                            
*** ERROR: `ethaddr' not set                                                    
*** ERROR: `ethaddr' not set     

My boards not booting ahead from above msg.

While same SD card booted up to linux login in i.MX6UL EVK.

Regards,

Pramod Kumar

Labels (1)
0 Kudos
1 Reply

76 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Pramod

for sd1 programming one can use mfg tool with script mfgtool2-yocto-mx-evk-sdcard-sd1.vbs

https://www.nxp.com/webapp/Download?colCode=IMX6_L4.9.11_1.0.0_MFG_TOOL&appType=license&location=nul... 

and use correct "mmcblkN" parameter as described in attached document Table 10. Common kernel boot parameters

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos