i.MX6 SABRE SDP Yocto Pocky with Midori error: No package 'webkit-1.0' found

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX6 SABRE SDP Yocto Pocky with Midori error: No package 'webkit-1.0' found

585 Views
josejurado
Contributor I


Hi,

 

I'm trying to compile the Yocto Pocky linux with Midori 0.5.2 browser (web kiosk image) and I get the next error (after solving a lot of previously errors):

 

...

| Checking for x11                            : 1.6.3

| Checking for header X11/extensions/scrnsaver.h : yes

| Checking for library Xss                       : yes

| Checking for gtk+-2.0 >= 2.16.0                : 2.24.28

| Checking for webkit-1.0 >= 1.1.17              : Package webkit-1.0 was not found in the pkg-config search path.

| Perhaps you should add the directory containing `webkit-1.0.pc'

| to the PKG_CONFIG_PATH environment variable

| No package 'webkit-1.0' found

| /home/jdavid/workspace/Yocto_k4/fsl-release-bsp/kiosk-build/tmp/work/cortexa9hf-vfp-neon-poky-linux-gnueabi/midori/0.5.2-r0/midori-0.5.2/wscript:190: error: the configuration failed (see '/home/jdavid/workspace/Yocto_k4/fsl-release-bsp/kiosk-build/tmp/work/cortexa9hf-vfp-neon-poky-linux-gnueabi/midori/0.5.2-r0/midori-0.5.2/_build/config.log')

| WARNING: exit code 2 from a shell command.

| ERROR: Function failed: do_configure (log file is located at /home/jdavid/workspace/Yocto_k4/fsl-release-bsp/kiosk-build/tmp/work/cortexa9hf-vfp-neon-poky-linux-gnueabi/midori/0.5.2-r0/temp/log.do_configure.20685)

ERROR: Task 1768 (/home/jdavid/workspace/Yocto_k4/fsl-release-bsp/sources/meta-web-kiosk/recipes-browser/midori/midori_0.5.2.bb, do_configure) failed with exit code '1'

...

 

I'm installed all required libraries and dependencies that I've found as solutions but not work for me:

 

$ sudo apt-get install libunique-dev libnotify libgtk2.0-dev libwebkit-dev libxml2-dev libsoup2.4-dev libsqlite3-dev valac libwebkitgtk-1.0-0  libwebkitgtk-1.0-common libwebkitgtk-common-dev libwebkit-dev libwebkit1.1-cil libwebkit-cil-dev libzeitgeist-1.0-1 libzeitgeist-dev

$ pkg-config —modversion webkit-1.0

 

and I also execute this commands that I see in one post:

 

$ cd $HOME/workspace/Yocto_k4/fsl-release-bsp/kiosk-build/tmp/work/cortexa9hf-vfp-neon-poky-linux-gnueabi/midori/0.5.2-r0/midori-0.5.2/

$ ./waf configure

$ ./waf build

$ sudo ./waf install

 

and work fine but compiling image continue failing.

 

The bitbake command is the next:

 

$ bitbake core-image-web-kiosk

 

Extra info:

- OS: Ubuntu 14.04.

- Device: imx6dlsabre for smart devices

 

The local.conf and bblayer file are attached.

 

Can anyone help me to solve this error? Thanks.

Original Attachment has been moved to: local.conf.zip

Original Attachment has been moved to: bblayers.conf.zip

0 Kudos
1 Reply

123 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Jose Jurado,

Are you still having problems to get the Web Kiosk working?I have not tested the Web Kiosk functionality but are you following the guidelines on the following document or what steps are you following?

https://wiki.yoctoproject.org/wiki/Web_Application_for_Interactive_Kiosk_Devices

If that’s the case it seems that the meta-web-kiosk layer should be on the poky path

${path_to_poky}/meta-web-kiosk         

Please let us know of your findings!

Regards,

0 Kudos