i.MX6 I2S slave mode

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX6 I2S slave mode

523 Views
宗標廖
Contributor V

Hello Community!

In the IMX6SDLRM,there are descriptions as bellow:

--------------------------------------------------------------------

In I2S slave mode(SSI_SCR[6:5]=10), the following settings are internally overridden by

the hardware:

. Normal mode is selected (SSI_SCR[3]=0)

--------------------------------------------------------------------

I am using L3.0.35_4.1.0 and I have not touched the SSI related drivers.When it is playing audio, I read the value of SSI1_SCR(addr:0x2028010),the value is 0x15F.

That is in I2S slave mode(SSI_SCR[6:5]=10), the Normal mode is selected (SSI_SCR[3]=1).

My questions are:

Q1):

why SSI_SCR[3] is not internally overridden by the hardware.

Q2):

Whether should I change  the imx-ssi.c to set the SSI_SCR[3] to 0?

Thank you!

Best Regards!

ZongbiaoLiao

Labels (3)
0 Kudos
3 Replies

92 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi ZongbiaoLiao

- "internally overridden by the hardware" means internally

module sees it as SSI_SCR[3]=0, ignoring user setting

-  seems this does not matter. NOte, official BSP release located

on nxp.com processor product page is tested and does not

require additional modifications. BSP package contains Release

Notes document describing what is supported and tested.

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos

92 Views
宗標廖
Contributor V

Hi igor

Could you give me a reply?

Thank you!

0 Kudos

92 Views
宗標廖
Contributor V

Hi,igor

Thank you for your reply!

But it does matter on my customer's board.

It is related to the channel swap issue.

Is it really OK to set SSI_SCR[3]=1 when SSI is working on I2S slave mode?

Best Regards!

ZongbiaoLiao

0 Kudos