i.MX53 - xserver-xorg-video-imx - imx-drm (imx-ldb for LVDS display) - mainline 3.12 kernel

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX53 - xserver-xorg-video-imx - imx-drm (imx-ldb for LVDS display) - mainline 3.12 kernel

Jump to solution
3,501 Views
flaviosuligoi
Contributor III

Hi all,

I'm using a 3.12 vanilla kernel for one of our boards with i.MX53, with a LVDS display.

I made all the changes required by our custom hw.

All works fine, the display works with the imx-drm driver and a standard xserver, using the framebuffer /dev/fb0.

The Debian desktop works on the board.

To increase the video performance, I'd like to use the apposite xserver-xorg-video-imx server.

I compiled a Yocto distribution, using the Freescale Yocto meta layers, as described in Freescale Yocto Project main page.

The xserver-xorg-video-imx starts, but doesn't recognize the frambuffer format of the imx-drm driver, as you can see (/dev/fb0 is not an imx device):

....

[2572194.363] (II) LoadModule: "imx"

[2572194.365] (II) Loading /usr/lib/xorg/modules/drivers/imx_drv.so

[2572194.421] (II) Module imx: vendor="X.Org Foundation"

[2572194.422]     compiled for 1.14.0, module version = 0.2.0

[2572194.422]     ABI class: X.Org Video Driver, version 14.1

[2572194.422] (II) imx: Driver for Freescale IMX processors: i.MX5x Z160

[2572194.423] (--) using VT number 3

[2572194.427] (WW) Falling back to old probe method for imx

[2572194.427] (II) Loading sub module "fbdevhw"

[2572194.427] (II) LoadModule: "fbdevhw"

[2572194.430] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so

[2572194.432] (II) Module fbdevhw: vendor="X.Org Foundation"

[2572194.433]     compiled for 1.14.0, module version = 0.0.2

[2572194.433]     ABI class: X.Org Video Driver, version 14.1

[2572194.433] (WW) /dev/fb0 is not an imx device:

[2572194.433] (EE) No devices detected.

[2572194.433]

Fatal server error:

[2572194.433] no screens found

[2572194.434] (EE)

....

Any ideas? Patch?

Thanks!

Flavio

Labels (4)
1 Solution
301 Views
kamillulko
Contributor III

Unfortunately you cannot use accelerated xorg drivers (or any gpu accelerated drivers for that matter) with mainline kernel on i.MX53 SoC (or any other i.MX Z430 GPU equipped SoC). The AMD Z430/Z160 is not supported in mainline and there seem to be no ports to newer kernels available. Newest port I have ever found was for 3.0.x Android kernel for some i.MX53 board (SMD I believe). Rob Clark from Freedreno project mentioned he might look into i.MX53 at some point but I predict this will not happen in near future.

In other words, since this xorg driver is using Z160 2D unit, you are out of luck here - stick with 2.6.35 kernel for gpu stuff.

View solution in original post

6 Replies
301 Views
Noel_V
Contributor III

Hi 

I'm trying to get accelerated xorg drivers with kernel 4.2.6 on i.MX53 SoC compiled, but bailing out for 1001 reasons.

Is there a known working kernel / xorg-accelerated driver  'pair' available that works out of the box,I just want to test the 'speed' difference accelerated vs not accelerated.

Or any patches , that could help me further in getting this to run ?

 

Regards

Noel

0 Kudos
301 Views
maxmustermann
Contributor I

Actually, I've got it running on 4.0.3.

Didn't test xorg yet, just Qt5+EGL.

But I'll have to give a BIG FAT WARNING:

Do NOT use the proprietary kernel / kgsl stuff. It's full of horrible security bugs and broken by design.

It gives the userland *FULL PHYSICAL* bus access - there's *NO SECURITY* anymore !

[imx53] WARNING! Do NOT use the proprietary GPU drivers / KGSL stuff - MAJOR RISK!

For the video stuff: that's not a matter of neither the GPUs or X - it's the V4l2 front.

Also got that running on 4.0.3 (eg. rebase'd some patches from ptx).

An fullscreen h264 video runs smoothly w/ 25fps. CPU load (70%) is still a bit high for my taste,

guess dma isn't properly utilized yet.

I'll post my patches on lklm in a few days.

0 Kudos
301 Views
fabio_estevam
NXP Employee
NXP Employee

Hi Flavio,

Does it work if you use a simple xorg.conf like this one:

recipes-graphics/xorg-xserver/xserver-xf86-config/mxs/xorg.conf ?

If you still have issues, please post it to meta-freescale@yoctoproject.org

Regards,

Fabio Estevam

0 Kudos
301 Views
flaviosuligoi
Contributor III

Hi Fabio,

Yes, I've used exactly this default xorg.conf !!!

See the attached complet Xorg logfile.

I think that it is not a Yocto related problem only.

But now my question is:  is the xserver-xorg-video-imx compatible with the old "official" Freescale kernel 2.6.35.3 only?

Another question: how can I use the DRM device driver imx-drm of 3.12 kernel, with all the hw video acceleration ?

Thank you for your help!

Flavio

0 Kudos
302 Views
kamillulko
Contributor III

Unfortunately you cannot use accelerated xorg drivers (or any gpu accelerated drivers for that matter) with mainline kernel on i.MX53 SoC (or any other i.MX Z430 GPU equipped SoC). The AMD Z430/Z160 is not supported in mainline and there seem to be no ports to newer kernels available. Newest port I have ever found was for 3.0.x Android kernel for some i.MX53 board (SMD I believe). Rob Clark from Freedreno project mentioned he might look into i.MX53 at some point but I predict this will not happen in near future.

In other words, since this xorg driver is using Z160 2D unit, you are out of luck here - stick with 2.6.35 kernel for gpu stuff.

View solution in original post

301 Views
flaviosuligoi
Contributor III

Thank you for your help Kamil!

Flavio

0 Kudos