i.MX53 WSXGA+ issue with xserver-xorg-video-imx

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX53 WSXGA+ issue with xserver-xorg-video-imx

532 Views
yukiikekita
Contributor I

Now we are trying to display WSXGA+(1680x1050) on LVDS LCD in Ubuntu,

using our custom board based on i.MX53 QSB-R.

LVDS configuration is as follows.

- One dual channel output: single input, split to two output channels

Most resolution (UXGA/1080p etc) except WSXGA+ can be displayed.

However, WSXGA+(1680x1050) can be displayed without "xserver-xorg-video-imx".

Are there any hardware or software limitations?

Additional information:

- Using the display driver : [xserver-xorg-video-imx_11.09.01_armel.deb] (latest)
   -> To display WSXGA+(1680x1050) on LVDS LCD is failure.

- Using the display driver : [xserver-xorg-video-imx_11.03.00-1_armel.deb]
   -> To display WSXGA+(1680x1050) on LVDS LCD is success, but video playback is failure.

Does anybody  know how to display WSXGA+ on LVDS LCD and do video playback

with the latest "xserver-xorg-video-imx"?

Labels (3)
0 Kudos
6 Replies

107 Views
jimmychan
NXP TechSupport
NXP TechSupport

Please check the FeatureMatrix_MX53.html of the Multimedia codec. You can see the max. resolution of video decoding is 1920x1080 (30fps).

0 Kudos

107 Views
yukiikekita
Contributor I

Thank you for your reply.

We resolved the video playback issue, but we don't know why i.MX53 can't display only this resolution (WSXGA+) with the latest driver.

Could you tell us how to display WSXGA+ on VGA monitor properly?

Other resolution is no problem.

0 Kudos

107 Views
jimmychan
NXP TechSupport
NXP TechSupport

As I mentioned before, the max. resolution of video decoding is 1920x1080 (30fps), so the video playback cannot display WSXGA+ resolution.

0 Kudos

107 Views
yukiikekita
Contributor I

WSXGA+ is 1680x1050, so I think WSXGA+ is smaller than Full HD (1920x1080).

0 Kudos

107 Views
jimmychan
NXP TechSupport
NXP TechSupport


Oh, sorry. I overlooked the resolution numbers. :smileyblush:

Have you build the Multimedia codec package?

0 Kudos

107 Views
yukiikekita
Contributor I

Yes, we have.
Video playback issue was solved by ourselves, so we would like to know why i.MX53 can't display properly the WSXGA+ resolution using xserver-xorg-video-imx_11.09.01_armel.deb on Ubuntu.

And we hope to display and play the MPEG2/4 video with this latest driver.

Have you ever seen the corrupted output is displayed on the monitor in WSXGA+ resolution?

0 Kudos