i.MX53 VPU debug method of rare issue which is difficult to reproduce

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX53 VPU debug method of rare issue which is difficult to reproduce

273 Views
torus1000
Contributor V

Hi chip experts,

Sometimes i.MX53 VPU_API returned following values then decoding process lost.

indexFrameDecoded = -1 #EOS not detected or skipped

indexFrameDisplay = -3 #decoder couldn't provide output

     where VPU_API = int indexFrameDisplay; or int indexFrameDecoded;

     See Page36 3.2.2.26 DecOutputInfo of i.MX5x_Linux_VPU_API.pdf

Is there any idea how to debug this issue?      e.g. set breakpoint somewhere in VPU_API

Can anyone help me ?

BR

Labels (2)
Tags (2)
0 Kudos
3 Replies

61 Views
joanxie
NXP TechSupport
NXP TechSupport

“indexFrameDecoded = -1” means there’s no frame buffer for next picture decoding.

Please check whether you call DecClrDispFlag each time a frame buffer is displayed and check whether you call DecRegisterFrameBuffer with enough frame buffers.

61 Views
torus1000
Contributor V

Dear Guanqiong,

Thank you for your reply.

According to the manual, DecRegisterFrameBuffer() normaly called once at first decoding, I'm not sure.
->See i.MX5x_Linux_VPU_API.pdf Page41 Figure 4.

(Q) Is it OK to call DecRegisterFrameBuffer() more than two times?

(Q) If yes, when and how can I call this DecRegisterFrameBuffer()?
    (Is there any restrictions to call?)

BR.

0 Kudos

61 Views
joanxie
NXP TechSupport
NXP TechSupport

yes, DecRegisterFrameBuffer is called before decoding, could you tell me why you need to call them again? in fact ,before decoding ,you can

allocate the proper size of the frame buffers by this function, you just need to use once, if you must use them again, pls tell me the reason.

0 Kudos