i.MX28 EVK in sato build, USB keyboard and mouse can't support

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX28 EVK in sato build, USB keyboard and mouse can't support

Jump to solution
592 Views
thomaslin
Contributor IV

Hi,

Already make i.MX28 EVK work by Yocto Sato UI build.

But USB keyboard and mouse can't work in this board. Both of them plug in J81 USB host port .

Do some check below

***** USB driver looks work by dmesg check *****

root@imx28evk:~# dmesg |grep usb                                    
usb DR wakeup device is registered                                  
IMX usb wakeup probe                                                
usbcore: registered new interface driver usbfs                      
usbcore: registered new interface driver hub                        
usbcore: registered new device driver usb                           
IMX usb wakeup probe                                                
usb h1 wakeup device is registered                                  
usbcore: registered new interface driver usb-storage                
usbcore: registered new interface driver hiddev                     
usbcore: registered new interface driver usbhid                     

usbhid: USB HID core driver 

***** Only find USB hub work by lsusb check *****                                       

root@imx28evk:~# lsusb                                              
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub      
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub      

******

Any idea to do USB keyboard/mouse check?


Labels (3)
0 Kudos
1 Solution
244 Views
thomaslin
Contributor IV

It work and problem gone.

1. Be master branch in repo

2. S16 set to WALL5V

View solution in original post

0 Kudos
3 Replies
244 Views
YixingKong
Senior Contributor IV

Thomas, please click Correct Answer if your issue is gone.

Thanks,

Yixing

0 Kudos
245 Views
thomaslin
Contributor IV

It work and problem gone.

1. Be master branch in repo

2. S16 set to WALL5V

View solution in original post

0 Kudos
244 Views
daiane_angolini
NXP Employee
NXP Employee

Yes.

Poky was recently updated and we faced the same issue you described.

It's caused by some evdev update/change. I was not able to figure out exactly what changed, but some previous configuration is not applicable with new evdev version.

Please, remove your tmp folder and pseudodone and make your image again. After that I had my mouse working again.

(and please, let me know the results)

0 Kudos