i.MX 6SoloX SDB L5.4.47_2.2.0 doesn't boot

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX 6SoloX SDB L5.4.47_2.2.0 doesn't boot

100 Views
Contributor I

Hi,

I'm trying to get the latest Linux 5.4.47_2.2.0​​ release to work on the i.MX 6SoloX SABRE Development Board. I have followed the instructions to build an image

repo init -u https://source.codeaurora.org/external/imx/imx-manifest  -b imx-linux-zeus -m imx-5.4.47-2.2.0.xml
repo sync
MACHINE=imx6sxsabresd DISTRO=fsl-imx-wayland source ./imx-setup-release.sh -b bld-wayland
bitbake imx-image-core

and flashed imx-image-core-imx6sxsabresd.wic to an SD card.

After switching on the board, it gets stuck in U-boot with the following output:

U-Boot 2020.04-5.4.47-2.2.0+gffc3fbe7e5 (Oct 30 2020 - 12:32:07 +0000)

CPU:   i.MX6SX rev1.2 996 MHz (running at 792 MHz)
CPU:   Extended Commercial temperature grade (-20C to 105C) at 29C
Reset cause: POR
Model: NXP i.MX6 SoloX SDB RevB Board
Board: MX6SX SABRE SDB revD
DRAM:  1 GiB
PMIC: PFUZE100! DEV_ID=0x11 REV_ID=0x21
MMC:   FSL_SDHC: 1, FSL_SDHC: 2, FSL_SDHC: 3
Loading Environment from MMC... *** Warning - bad CRC, using default environment

Display: Hannstar-XGA (1024x768)
Video: 1024x768x18
In:    serial
Out:   serial
Err:   serial
switch to partitions #0, OK
mmc3 is current device
flash target is MMC:3
Net:   Could not get PHY for FEC0: addr 1
Could not get PHY for FEC0: addr 1
Get shared mii bus on ethernet@21b4000

Same configuration with the older Linux 5.4.3_1.0.1​​ is working as expected.

I also tried the pre-built images from L5.4.47-2.2.0_images_MX6QPDLSOLOX.zip and flashed imx-image-multimedia-imx6qpdlsolox.wic, but in this case I only see repeated "66666..." on the console output. When using the instructions from the i.MX Linux Users Guide to partition the SD card and manually copy the bootloader image, I see the same U-boot output as with my own built images above.

Any idea what's going wrong here and how to fix it? Thanks.

BR, Mario

0 Kudos
8 Replies

80 Views
Contributor I

Hi @Yuri,

I'm using Rufus under Windows to flash the .wic image to SD card. Also tried with

sudo dd if=<image name>.wic of=/dev/sd<partition> bs=1M conv=fsync

under Linux, but it's giving the same result. With older releases (5.4.3_1.0.1), this is working fine.

Regards,
Mario

0 Kudos

74 Views
NXP TechSupport
NXP TechSupport

@mariozessack 
 

  Please try using the UUU, as recommended in section 4.2 (Universal update utility)
of i.MX Linux® User's Guide, Rev. L5.4.47. 

Regards,
Yuri.

0 Kudos

71 Views
Contributor I

@Yuri 

my imx6sxsabresd doesn't have eMMC populated. I tried writing the bootloader (from L5.4.47-2.2.0_images_MX6QPDLSOLOX.zip) to SD card using UUU with the board in serial download mode:

d:\>uuu.exe -b sd u-boot-imx6sxsabresd_sd.imx
uuu (Universal Update Utility) for nxp imx chips -- libuuu_1.4.43-0-ga9c099a

Success 0 Failure 0


1:211 1/ 1 [=================100%=================] SDP: boot -f u-boot-imx6sxsabresd_sd.imx

Output from the board:

U-Boot 2020.04-5.4.47-2.2.0+gffc3fbe7e5 (Sep 12 2020 - 03:20:21 +0000)

CPU:   i.MX6SX rev1.2 996 MHz (running at 792 MHz)
CPU:   Extended Commercial temperature grade (-20C to 105C) at 35C
Reset cause: POR
Model: NXP i.MX6 SoloX SDB RevB Board
Board: MX6SX SABRE SDB revD
DRAM:  1 GiB
PMIC: PFUZE100! DEV_ID=0x11 REV_ID=0x21
MMC:   FSL_SDHC: 1, FSL_SDHC: 2, FSL_SDHC: 3
Loading Environment from MMC... *** Warning - bad CRC, using default environment

Display: Hannstar-XGA (1024x768)
Video: 1024x768x18
In:    serial
Out:   serial
Err:   serial
switch to partitions #0, OK
mmc3 is current device
flash target is MMC:3
Net:   Could not get PHY for FEC0: addr 1
Could not get PHY for FEC0: addr 1
Get shared mii bus on ethernet@21b4000

Still gets stuck afterwards.

Regards,
Mario

0 Kudos

59 Views
Contributor I

@Yuri 

I can successfully flash and boot from SD card using emmc u-boot configuration as below:

uuu.exe -b sd_all u-boot-imx6sxsabresd_emmc.imx imx-image-core-imx6sxsabresd.wic.bz2/*

sd u-boot images do not seem to work.

To build emmc configuration for imx6sxsabresd, I had to overwrite UBOOT_CONFIG_imx6sxsabresd = "emmc" in meta-imx/meta-bsp/conf/layer.conf, since this is set to sd/sd-optee by default.

Regards,
Mario

0 Kudos

66 Views
NXP TechSupport
NXP TechSupport

@mariozessack 

   What is U-boot environment ?

 

~Yuri.

0 Kudos

64 Views
Contributor I

@Yuri 

How do I check this? It should be the default, built-in environment according to this line:

Loading Environment from MMC... *** Warning - bad CRC, using default environment

BR, Mario

0 Kudos

40 Views
NXP TechSupport
NXP TechSupport

@mariozessack 
Hello,

   Use U-boot command "printenv".

Regards,
Yuri.

 

0 Kudos

85 Views
NXP TechSupport
NXP TechSupport

@mariozessack 
Hello,

  Please let me know how the (demo) image was transferred to boot media in Your case.
Have You applied UUU. DO You have a corresponding log?

Regards,
Yuri.

0 Kudos