how to install zlib for ltib installation ..??

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

how to install zlib for ltib installation ..??

3,578 Views
viswanathkondap
Contributor I

HP-xw4400-Workstation:~/Desktop/L3.0.35_4.1.0_130816_source/ltid/ltib$ ./ltib

defined(@array) is deprecated at /home/cyient/Desktop/L3.0.35_4.1.0_130816_source/ltid/ltib/bin/Ltibutils.pm line 362.

    (Maybe you should just omit the defined()?)

ltib cannot be run because one or more of the host packages needed to run it

are either missing or out of date or not in ltib's standard path.  Please

install/upgrade these packages on your host.  If you have your own utilities

in non-standard paths, please add an entry into the .ltibrc file for example:

%path_std

/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/my/own/exes

Package                Minimum ver   Installed info

-------                -----------   ---------------

zlib                   0             not installed

Died at ./ltib line 1409.

traceback:

main::host_checks:1409

  main:554

Started: Tue Jan 20 11:45:13 2015

Ended:   Tue Jan 20 11:45:15 2015

Elapsed: 2 seconds

Build Failed

Exiting on error or interrupt

Labels (6)
Tags (1)
0 Kudos
7 Replies

1,781 Views
dumitrupopa
Contributor I

Hello Viswa,

can you tell us what you do exact to resolve that issue ?

I am in same situation, but I don't have find yet a solution.

Thank you,

PopaD

0 Kudos

1,780 Views
igorpadykov
NXP Employee
NXP Employee

Hi Viswanath

first please install packages as suggests attached document.

Also, for example, various Ubuntu distributions can move libs to different locations,

so ltib fails find them. Below links may be helpful.

i.MX Linux BSP Environment Setup

https://community.freescale.com/docs/DOC-93454

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos

1,779 Views
viswanathkondap
Contributor I

OK and I am installing the list of paclages now. and i am following this link : https://community.freescale.com/docs/DOC-100725

before this i got "zlib not installed" and the build was failed.

defined(@array) is deprecated at /home/cyient/Desktop/L3.0.35_4.1.0_130816_source/ltid/ltib/bin/Ltibutils.pm line 362.

(Maybe you should just omit the defined()?)

ltib cannot be run because one or more of the host packages needed to run it are either missing or out of date or not in ltib's standard path. Please install/upgrade these packages on your host. If you have your own utilities

in non-standard paths, please add an entry into the .ltibrc file for example:

%path_std

/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/my/own/exes

Package Minimum ver Installed info

0 Kudos

1,780 Views
igorpadykov
NXP Employee
NXP Employee

first one needs to install packages in attached document.

Recommended to erase all old builds and try a new fresh build.

0 Kudos

1,780 Views
viswanathkondap
Contributor I

I installed all the packs and tools and also applied the patch for 14.04 ubuntu also but i got an build faild.

can you please help in this:

cyient@cyient-HP-xw4400-Workstation:~/Desktop/L3.0.35_4.1.0_130816_source/ltib/ltib$ ./ltib

I ran the command: sudo -S -l which returned:

Matching Defaults entries for cyient on cyient-HP-xw4400-Workstation:

env_reset, mail_badpass, secure_path=/usr/local/sbin\:/usr/local/bin\:/usr/sbin\:/usr/bin\:/sbin\:/bin

User cyient may run the following commands on cyient-HP-xw4400-Workstation:

(ALL : ALL) ALL

This means you don't have sudo permission to execute rpm commands as root

without a password. This is needed for this build script to operate correctly.

To configure this, as root using the command "/usr/sbin/visudo",

and add the following line in the User privilege section:

cyient ALL = NOPASSWD: /usr/bin/rpm, /opt/freescale/ltib/usr/bin/rpm

traceback:

main::check_sudo_setup:2467

main::host_checks:1413

main:554

Started: Tue Jan 20 14:44:27 2015

Ended: Tue Jan 20 14:44:27 2015

Elapsed: 0 seconds

Build Failed

Exiting on error or interrupt

cyient@cyient-HP-xw4400-Workstation:~/Desktop/L3.0.35_4.1.0_130816_source/ltib/ltib$

regards,

Viswanath K

0 Kudos

1,780 Views
igorpadykov
NXP Employee
NXP Employee

for "sudo permission" please look at

http://cache.freescale.com/files/dsp/doc/app_note/AN3875.pdf  p.44

0 Kudos

1,780 Views
viswanathkondap
Contributor I

Thnx for the help.i included the few paths in the suoders so that ltib packages are installed.

thnk u once again for the response.

regards,

Viswa.

0 Kudos