how osd work on imx6q?

cancel
Showing results for 
Search instead for 
Did you mean: 

how osd work on imx6q?

Jump to solution
583 Views
stevenhuang
Contributor III

I wan the video as the input of fb0, QT frame as the input of fb1; video is background, QT  picture is front, but no QT picture been display.  Where can i find document about this issue?

Labels (1)
0 Kudos
1 Solution
278 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi 友 杨 

please check below links which may help

IPUv3 frame buffer question (./driver/video/mxc/mxc_ipuv3_fb.c) 

i.MX6: fb2 Framebuffer issue 

A Deep Dive into Image Processing for i.MX 6 Series Applications Processors 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

4 Replies
278 Views
yyuan
Contributor III

hello

please  do you solve the peoblem?

i have the same problem.

please help me

thank you

0 Kudos
278 Views
stevenhuang
Contributor III

I  am sorry,  the FB0 is FG, fb1 is BG. but i fond the BG have no any picture display.

0 Kudos
279 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi 友 杨 

please check below links which may help

IPUv3 frame buffer question (./driver/video/mxc/mxc_ipuv3_fb.c) 

i.MX6: fb2 Framebuffer issue 

A Deep Dive into Image Processing for i.MX 6 Series Applications Processors 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

278 Views
stevenhuang
Contributor III

thank you,  i have fixed my issue: the alpha value is 0 by default, so the BG can't display.

0 Kudos