gst-launch issue with yocto build of i.mx8mmevk

cancel
Showing results for 
Search instead for 
Did you mean: 

gst-launch issue with yocto build of i.mx8mmevk

Jump to solution
268 Views
Contributor III

gst-launch-1.0 v4l2src device=/dev/video0 ! video/x-raw,width=1920,height=1080 ! waylandsink

works on the NXP-provided L4.14.90_2.0.0_ga_images_MX8MMEVK/fsl-image-validation-imx-imx8mmevk.sdcard.

pastedImage_4.png

However, if I use Yocto to build the image using:

DISTRO=fsl-imx-wayland MACHINE=imx8mmevk source fsl-setup-release.sh -b build-wayland

bitbake fsl-image-validation-imx

I just get a black screen with the above gst-launch-1.0 command:

pastedImage_3.png

Any advice?

Jeff

Labels (1)
0 Kudos
1 Solution
43 Views
Contributor III

Problem solved.

gstreamer does not work properly with the this DISTRO.

DISTRO=fsl-imx-wayland MACHINE=imx8mmevk source fsl-setup-release.sh -b build-wayland

 

I have to use:

DISTRO=fsl-imx-xwayland MACHINE=imx8mmevk source fsl-setup-release.sh -b build-xwayland

I have seen comments in community.nxp.com where people have said fsl-imx-wayland is ok, but it really depends on what you are trying to do. Just note, I have found gstreamer does NOT work with this. You need to use fsl-imx-xwayland. I don't know the exact root cause (already spend countless hours building different recipes), but hopefully this helps the rest of you.

Jeff

View solution in original post

0 Kudos
10 Replies
43 Views
Contributor III

I found fsl-image-validation-imx-imx8mmevk.manifest in both the NXP demo folder and my local Yocto build folder and when I compare the two they are quite different. I looked at the file SCR-4.14.98_2.0.0_ga and it lists some patches that were added to the META_FSL_BSP_RELEASE. I am not sure if this is relevant. Of the ones I diffed,  I see the ones related to gstreamer but I am guessing these don't matter.


gstreamer1.0-plugins-base-ximagesink aarch64_mx8mm 1.14.4.imx
gstreamer1.0-plugins-base-xvimagesink aarch64_mx8mm 1.14.4.imx
gstreamer1.0-plugins-good-ximagesrc aarch64_mx8mm 1.14.4.imx

0 Kudos
43 Views
Contributor III

I reran the Yocto flow using Ubuntu 16.04.1 and I now see a very dark image from gst-launch. Any advice for debugging this issue?

0 Kudos
43 Views
NXP TechSupport
NXP TechSupport

did you try to use demo image first? if still has the same issue, pls tell me what image and dtb file in demo image you use, let me reproduce this on my board,

0 Kudos
43 Views
Contributor III

Thanks for your reply. Which demo image are you referring to?

0 Kudos
43 Views
Contributor III

I had a typo in my original reference to what worked:

The NXP provided image L4.14.98_2.0.0_ga_images_MX8MMEVK/fsl-image-validation-imx-imx8mmevk.sdcard works. But when I try to build using Yocto, it fails.

0 Kudos
43 Views
NXP TechSupport
NXP TechSupport

yes I know that .sdcard in demo image works, I mean that you can try the demo kenerl image instead of your own built image to test first

0 Kudos
43 Views
Contributor III

Please elaborate the steps as I am relatively new to this process.

0 Kudos
44 Views
Contributor III

Problem solved.

gstreamer does not work properly with the this DISTRO.

DISTRO=fsl-imx-wayland MACHINE=imx8mmevk source fsl-setup-release.sh -b build-wayland

 

I have to use:

DISTRO=fsl-imx-xwayland MACHINE=imx8mmevk source fsl-setup-release.sh -b build-xwayland

I have seen comments in community.nxp.com where people have said fsl-imx-wayland is ok, but it really depends on what you are trying to do. Just note, I have found gstreamer does NOT work with this. You need to use fsl-imx-xwayland. I don't know the exact root cause (already spend countless hours building different recipes), but hopefully this helps the rest of you.

Jeff

View solution in original post

0 Kudos
43 Views
Contributor III

If you are referring to videotestsrc:

I run this and I get a green screen which is not what it is supposed to do.

gst-launch-1.0 -v videotestsrc ! autovideosink

0 Kudos