glfinish takes 5ms for nothing

cancel
Showing results for 
Search instead for 
Did you mean: 

glfinish takes 5ms for nothing

181 Views
Contributor III

I'm currently trying to find bottlenecks, as I'm currently not able to archive a full-hd rendering of a texture at 60fps when some additional small overlays are present.

During my timing tests I found out that calling glFinish with no OpenGL command in the queue it already takes 4-5ms before glFinish returns. Is this due to the context switch to kernel space?
But even in case that's the main reason for a delay, it seems quite a bit long to me.

Apart from that, is there an easy way to enable the vivante profiler within the yocto toolchain? I couldn't find an option within the kernel menuconfig, although there seems to be a USE_PROFILER option somewhere to be defined.

At least this option is parsed in the KBuild file under drivers/mxc/gpu-viv.

Labels (3)
Tags (1)
0 Kudos
1 Reply

6 Views
NXP TechSupport
NXP TechSupport

I guess for the latest branch In  Yocto the The 3.10.17-1.0.0 GPU has been updated to vivante 4.6.9p13 release. This patch updates the kernel driver to be compatible with it. And it includes the USE_PROFILES flags definitions in order to use and enable Vivante_PROFILER =1

In the VIVANTE_PROFILER_CONTEXT

Hope this helps

0 Kudos