[fsl-image-qt5-validation-imx] vulkan_1.0.65.2.bb:do_compile failed

cancel
Showing results for 
Search instead for 
Did you mean: 

[fsl-image-qt5-validation-imx] vulkan_1.0.65.2.bb:do_compile failed

Jump to solution
4,784 Views
takashi_kashiwa
Senior Contributor I

Hi all.

I'm trying to build fsl-image-qt5-validation-imx for IMX8MQEVK, but bitbake is stopped by vulkan:do_compile failure.

A part of do_compile errors is as follows. Does anyone know the solution?

(I do not know vulkan well, but it looks like there are not some files.)

* Building parameter_validation.cpp
Error: Could not find vk_validation_error_messages.h
~~~
aarch64-poky-linux-g++: error: layers/parameter_validation.cpp: No such file or directory
aarch64-poky-linux-g++: fatal error: no input files

I atach the log file. 

Other information is as follows.

  • I used SDK Standalone shell ("x86_64-buildtools-nativesdk-standalone-2.6.sh").
  • I read "i.MX Yocto Project User's Guide" Rev. L4.14.78-1.0.0_ga, 01/2019.
  • The log when executing the bitbake command is as follows.

$ bitbake fsl-image-qt5-validation-imx
NOTE: Your conf/bblayers.conf has been automatically updated.
WARNING: Host distribution "ubuntu-18.04" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.
Parsing recipes: 100% |##########################################| Time: 0:05:59
Parsing of 2548 .bb files complete (0 cached, 2548 parsed). 3464 targets, 220 skipped, 7 masked, 0 errors.
NOTE: Resolving any missing task queue dependencies
NOTE: Multiple providers are available for runtime ptpd (ptpd, ptpd-qoriq)
Consider defining a PREFERRED_RPROVIDER entry to match ptpd
NOTE: Multiple providers are available for runtime ptpd-dev (ptpd, ptpd-qoriq)
Consider defining a PREFERRED_RPROVIDER entry to match ptpd-dev
Build Configuration:
BB_VERSION           = "1.38.0"
BUILD_SYS            = "x86_64-linux"
NATIVELSBSTRING      = "ubuntu-18.04"
TARGET_SYS           = "aarch64-poky-linux"
MACHINE              = "imx8mqevk"
DISTRO               = "fsl-imx-xwayland"
DISTRO_VERSION       = "4.14-sumo"
TUNE_FEATURES        = "aarch64"
TARGET_FPU           = ""
meta                
meta-poky            = "HEAD:64a257fa22126c4a40ff7e03424a404e360ebe1e"
meta-oe             
meta-multimedia      = "HEAD:2bb21ef27c4b0c9d52d30b3b2c5a0160fd02b966"
meta-freescale       = "HEAD:407c6cf408969445031a492e2d25e0e2749582ea"
meta-freescale-3rdparty = "HEAD:88a29631809d1af0df618245430db29f2a7012b5"
meta-freescale-distro = "HEAD:f7e2216e93aff14ac32728a13637a48df436b7f4"
meta-bsp            
meta-sdk             = "HEAD:9867dae67c158e0820bf226bd18b792623e99b25"
meta-browser         = "HEAD:75640e14e325479c076b6272b646be7a239c18aa"
meta-gnome          
meta-networking     
meta-python         
meta-filesystems     = "HEAD:2bb21ef27c4b0c9d52d30b3b2c5a0160fd02b966"
meta-qt5             = "HEAD:d4e7f73d04e8448d326b6f89908701e304e37d65"
Initialising tasks: 100% |#######################################| Time: 0:00:18
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks

Best Regards,

T.Kashiwagi

1 Solution
1,133 Views
ernestlih
Contributor II

Hello Yuri,

My issue, vulkan error, was cleared after python update (exactly, essential package update).

Thanks a lot.

Regards,

Ernest

View solution in original post

14 Replies
1,133 Views
janakiram_sistl
Contributor III

@vincent.aubineau Employee Thank you for a quick reply. I did try to use bitbake -k fsl-image-validation-imx and i was able to build the rest of the repo . But this error w.r.t Vulkan doesnt go away. 

Regards,
Sistla. 

1,133 Views
vincent_aubinea
NXP Employee
NXP Employee

Hi,

Maybe you can check which packages are installed on your Linux machine.

I have enclosed my Ubuntu package list installed on my machine. I did the following command to get it:

dpkg -l‍ > my_file.txt

Here is my Ubuntu version:

$ uname -a
Linux fsl-Precision-M4601 4.18.0-18-generic #19~18.04.1-Ubuntu SMP Fri Apr 5 10:22:13 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

BR

Vincent

0 Kudos
1,133 Views
mueller12
Contributor III

For the python issue during vulkan build try bbappend the vulkan recipe and set:

OECMAKE_GENERATOR = "Unix Makefiles"

maybe because of ubuntu 18.04 is labeled untested with sumo ...

1,133 Views
ernestlih
Contributor II

Thanks for sharing information.

However it's not working to me.

Regards,

Ernest

0 Kudos
1,133 Views
Yuri
NXP TechSupport
NXP TechSupport

Hello,

  Please use the following general Yocto recommendations regarding host setup,

perhaps some packages on Your host should be updated / upgraded. 

(In particular - Python 3.4.0 or greater)

Yocto Project Reference Manual  

Regards,

Yuri.

1,134 Views
ernestlih
Contributor II

Hello Yuri,

My issue, vulkan error, was cleared after python update (exactly, essential package update).

Thanks a lot.

Regards,

Ernest

View solution in original post

1,133 Views
takashi_kashiwa
Senior Contributor I

Hi YuriMuhin_ng and ernestlih

I executed "repo sync" and "bitbake" some times, fsl-image was created!

(When building on 24 Feb, "bblayers".conf was updated.)

For now, I do not know why the python script failed (poky/meta/recipes-graphics/vulkan/vulkan_1.0.65.2.bb:do_compile).

So I'm not sure what was the cause......

As a precaution, the result of "repo info" is as follows.

Manifest branch:
Manifest merge branch: refs/heads/imx-linux-sumo
Manifest groups: all,-notdefault
----------------------------
Project: fsl-community-bsp-base
Mount path: /home/tkashi/imx-yocto-bsp/sources/base
Current revision: 70535e13dd2aabbad53243518f4cc5064d284592
Local Branches: 0
----------------------------
Project: meta-browser
Mount path: /home/tkashi/imx-yocto-bsp/sources/meta-browser
Current revision: 75640e14e325479c076b6272b646be7a239c18aa
Local Branches: 0
----------------------------
Project: meta-freescale
Mount path: /home/tkashi/imx-yocto-bsp/sources/meta-freescale
Current revision: 407c6cf408969445031a492e2d25e0e2749582ea
Local Branches: 0
----------------------------
Project: meta-freescale-3rdparty
Mount path: /home/tkashi/imx-yocto-bsp/sources/meta-freescale-3rdparty
Current revision: 88a29631809d1af0df618245430db29f2a7012b5
Local Branches: 0
----------------------------
Project: meta-freescale-distro
Mount path: /home/tkashi/imx-yocto-bsp/sources/meta-freescale-distro
Current revision: f7e2216e93aff14ac32728a13637a48df436b7f4
Local Branches: 0
----------------------------
Project: meta-fsl-bsp-release
Mount path: /home/tkashi/imx-yocto-bsp/sources/meta-fsl-bsp-release
Current revision: 9867dae67c158e0820bf226bd18b792623e99b25
Local Branches: 0
----------------------------
Project: meta-openembedded
Mount path: /home/tkashi/imx-yocto-bsp/sources/meta-openembedded
Current revision: 2bb21ef27c4b0c9d52d30b3b2c5a0160fd02b966
Local Branches: 0
----------------------------
Project: meta-qt5
Mount path: /home/tkashi/imx-yocto-bsp/sources/meta-qt5
Current revision: d4e7f73d04e8448d326b6f89908701e304e37d65
Local Branches: 0
----------------------------
Project: poky
Mount path: /home/tkashi/imx-yocto-bsp/sources/poky
Current revision: 64a257fa22126c4a40ff7e03424a404e360ebe1e
Local Branches: 0
----------------------------

Best Regards,

T.Kashiwagi

0 Kudos
1,133 Views
Yuri
NXP TechSupport
NXP TechSupport

Hello,

 

   The following may help:

1) to build core-image-minimal system first;

2) use fetchall option: 

    bitbake -c fetch fsl-image-validation-imx

 


Have a great day,
Yuri

1,133 Views
vincent_aubinea
NXP Employee
NXP Employee

Hi Yuri,

Thanks for the hints, now I can go further...

I have a brand new Ubuntu 18.04 with 8 cores (meaning 8 packages built in parallel), and I was stuck later in tesseract-lang-3.04 build.

I have relaunched the bitbake several times (and maybe a dependance was missing? as I was able to build new packages in parellel at each new build attempt) and now it is built!

thx

Vincent

1,133 Views
Yuri
NXP TechSupport
NXP TechSupport

Hello,

  You wrote, that the "i.MX Yocto Project User's Guide" has been read (that's great!),

but have You tried to follow its instructions exactly, say under default Linux shell?  


Have a great day,
Yuri

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

1,133 Views
takashi_kashiwa
Senior Contributor I

Hi Yuri

Thank you for responding.

but have You tried to follow its instructions exactly, say under default Linux shell?

Yes(I wish I had not mistaken the command.......:smileycry:).

I used gonme-shell and executed commands  as follows.

 

$ sudo apt-get install gawk wget git-core diffstat unzip texinfo gcc-multilib build-essential chrpath socat cpio python python3 python3-pip python3-pexpect xz-utils debianutils iputils-ping
$ sudo apt-get install libsdl1.2-dev xterm sed cvs subversion coreutils texi2html docbook-utils python-pysqlite2 help2man make gcc g++ desktop-file-utils libgl1-mesa-dev libglu1-mesa-dev mercurial autoconf automake groff curl lzop asciidoc
$ sudo apt-get install libsdl1.2-dev xterm
$ sudo apt-get install make xsltproc docbook-utils fop dblatex xmlto
$ sudo apt-get install python-git
$ chmod u+x x86_64-buildtools-nativesdk-standalone-2.6.1.sh
$ ./x86_64-buildtools-nativesdk-standalone-2.6.1.sh
$ sudo apt-get install gawk wget git-core diffstat unzip texinfo gcc-multilib build-essential chrpath socat libsdl1.2-dev
$ mkdir ~/bin
$ chmod a+x ~/bin/repo
$ export PATH=~/bin:$PATH
$ git config --global user.name "****************"
$ git config --global user.email "****************@**************"
$ git config --list
$ mkdir imx-yocto-bsp
$ cd imx-yocto-bsp
$ repo init -u https://source.codeaurora.org/external/imx/imx-manifest -b imx-linux-sumo -m imx-4.14.78-1.0.0_ga.xml
$ repo sync
$ DISTRO=fsl-imx-xwayland MACHINE=imx8mqevk source fsl-setup-release.sh -b build-xwayland
$ bitbake fsl-image-qt5-validation-imx
Best Regards,
T.Kashiwagi
0 Kudos
1,133 Views
Yuri
NXP TechSupport
NXP TechSupport

Hello!

   Please try "repo sync", and run the build again.

Also, You may  try to use xwayland:

$ DISTRO=fsl-imx-xwayland MACHINE=imx8mqevk source fsl-setup-release.sh -b build-xwayland

$ bitbake fsl-image-qt5-validation-imx

Regards,

Yuri.

0 Kudos
1,133 Views
ernestlih
Contributor II

Hi,

I have encountered the same error. I have tried "repo sync" and "bitbake fsl-image-qt5-validation-imx" several times. However it is never fixed.

Build Configuration:
BB_VERSION           = "1.38.0"
BUILD_SYS            = "x86_64-linux"
NATIVELSBSTRING      = "ubuntu-16.04"
TARGET_SYS           = "aarch64-poky-linux"
MACHINE              = "imx8mqevk"
DISTRO               = "fsl-imx-xwayland"
DISTRO_VERSION       = "4.14-sumo"
TUNE_FEATURES        = "aarch64"
TARGET_FPU           = ""
meta                 
...

...

* Building parameter_validation.cpp
| Error: Could not find vk_validation_error_messages.h

...

...

_validation.dir/parameter_validation.cpp.o -c layers/parameter_validation.cpp
| aarch64-poky-linux-g++: error: layers/parameter_validation.cpp: No such file or directory
| aarch64-poky-linux-g++: fatal error: no input files
| compilation terminated.
| ninja: build stopped: subcommand failed.
| WARNING: exit code 1 from a shell command.
| ERROR: Function failed: do_compile (log file is located at /home/mv/imx-yocto-bsp/build-xwayland_4.14.78/tmp/work/aarch64-mx8m-poky-linux/vulkan/1.0.65.2-r0/temp/log.do_compile.6031)
ERROR: Task (/home/mv/imx-yocto-bsp/sources/poky/meta/recipes-graphics/vulkan/vulkan_1.0.65.2.bb:do_compile) failed with exit code '1'

Regards,

Ernest

0 Kudos
1,133 Views
takashi_kashiwa
Senior Contributor I

Hi Yuri

 

Thank you for responding.

Please try "repo sync", and run the build again.

OK. I will run the build again with xwayland.

Please wait for a while until the build is completed.

Best Regards,

T.Kashiwagi

0 Kudos