failing to get the console

cancel
Showing results for 
Search instead for 
Did you mean: 

failing to get the console

527 Views
pravverma
Contributor III

Hi,

While booting kernel 4.12 from collabora git for IMX6Q based sabresd, I am failing to get the console.

Starting Bootlog daemon: bootlogd: cannot find console device 0:0 under /dev
bootlogd.
Populating dev cache
ALSA: Restoring mixer settings...
No state is present for card wm8962audio
Found hardware: "wm8962-audio" "" "" "" ""
Hardware is initialized using a generic method
No state is present for card wm8962audio
Configuring network interfaces... /etc/network/if-pre-up.d/nfsroot: line 12: 0: Bad file descriptor
run-parts: /etc/network/if-pre-up.d/nfsroot exited with code 1
done.
Starting rpcbind daemon...done.
hwclock: settimeofday: Invalid argument
Wed Oct 29 08:50:00 UTC 2014
INIT: Entering runlevel: 5
Starting system message bus: dbus.
UIM SYSFS Node Not Found
Starting telnet daemon.
creating NFS state directory: done
NFS daemon support not enabled in kernel
Starting syslogd/klogd: done
Starting thttpd.
Stopping Bootlog daemon: bootlogd.
INIT: Id "1" respawning too fast: disabled for 5 minutes
INIT: Id "mxc0" respawning too fast: disabled for 5 minutes
INIT: no more processes left in this runlevel
[ 157.505240] random: crng init done

But with the clone of kernel4.12 from link https://github.com/Freescale/linux-fslc.git.
i am successfully getting the console


Starting Bootlog daemon: bootlogd: cannot allocate pseudo tty: No such file or directory
bootlogd.
Populating dev cache
ALSA: Restoring mixer settings...
No state is present for card wm8962audio
Found hardware: "wm8962-audio" "" "" "" ""
Hardware is initialized using a generic method
No state is present for card wm8962audio
Configuring network interfaces... [ 11.143439] Atheros 8031 ethernet 2188000.ethernet-1:01: attached PHY driver [Atheros 8031 ethernet] (mii_bus:phy_addr=2188000.ethernet-1:01, irq=-1)
[ 11.157724] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
udhcpc (v1.21.1) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing
done.
Starting rpcbind daemon...done.
hwclock: settimeofday: Invalid argument
Wed Oct 29 08:50:00 UTC 2014
INIT: Entering runlevel: 5
Starting system message bus: dbus.
UIM SYSFS Node Not Found
Starting telnet daemon.
creating NFS state directory: done
NFS daemon support not enabled in kernel
Starting syslogd/klogd: done
Starting thttpd.
Stopping Bootlog daemon: bootlogd.

login: root
#

I am not succeeding in finding the problem. Please help me

Thanks.

Labels (2)
0 Kudos
1 Reply

206 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Praveen Verma,

Does this problem continues? Perhaps it would be good to contact the people maintaining the collabora git. I would hope that the update with the patches and fixes of the FSL Community BSP from time to time.

Regards,

0 Kudos