eth0 down hangs after 10 minutes in 3.10.17 freescale release

cancel
Showing results for 
Search instead for 
Did you mean: 

eth0 down hangs after 10 minutes in 3.10.17 freescale release

1,637 Views
jestinajoy
Contributor I

Hi,

I am using a custom board with imx6 solo  with 3.10.17 freescale kernel release. If i give  'ifconfig eth0 down ' ,after  10 minutes(approximate)   the system gets hang. The issue is noted when i change the kernel from 3.10.9 to 3.10.17. When we down the interface "Link is Down" message is not coming. Adding some log info:

# ifconfig 

eth0 Link encap:Ethernet HWaddr d8:b8:ff:03:7f:85 

  inet addr:172.20.2.128 Bcast:172.20.2.255 Mask:255.255.255.0 

  inet6 addr: fe80::dab8:ffff:fe03:7f85/64 Scope:Link 

  UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 

  RX packets:12992 errors:0 dropped:0 overruns:0 frame:0 

  TX packets:330 errors:0 dropped:0 overruns:0 carrier:0 

  collisions:0 txqueuelen:1000 

  RX bytes:1184770 (1.1 MB) TX bytes:33144 (33.1 KB)

# lshw -C network 

  *-network:0 

  description: Wireless interface 

  physical id: 1 

  logical name: wlan0 

  serial: e0:c7:9d:35:51:2e 

  capabilities: ethernet physical wireless 

  configuration: broadcast=yes driver=wl18xx_driver driverversion=3.10.17 firmware=Rev 8.8.0.0.13 link=no multicast=yes wirn

  *-network:1 

  description: Ethernet interface 

  physical id: 2 

  logical name: eth0 

  serial: d8:b8:ff:03:7f:85 

  size: 100Mbit/s 

  capacity: 100Mbit/s 

  capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation 

  configuration: autonegotiation=on broadcast=yes driver=fec driverversion=Revision: 1.0 duplex=full ip=172.20.2.128 link=ys

# dmesg |grep eth0 

fec 2188000.ethernet eth0: registered PHC device 0 

fec 2188000.ethernet eth0: Freescale FEC PHY driver [SMSC LAN8710/LAN8720] (mii_bus:phy_addr=2188000.ethernet:01, irq=-1)

IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready 

IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready \

Labels (1)
2 Replies

153 Views
simonmarchant
Contributor I

Hi,

I realise this is an old post but I am now having this issue with the iMX6ULL. We are using an SMSC PHY but the problem remains if I use the Generic PHY driver.

Was a solution for for this issue?

thanks,

simon

0 Kudos

153 Views
gusarambula
NXP TechSupport
NXP TechSupport

It’s most likely that the problem is related to the driver and not the FEC itself.

If you are using the LAN8720 PHY maybe the following thread might help:

https://community.freescale.com/message/331971#331971

Maybe this entry from an external site may also be useful:

http://u-boot.10912.n7.nabble.com/imx6-Solo-and-LAN8720-td171669.html

0 Kudos