eglSwapBuffers() can't display content on screen immediately

cancel
Showing results for 
Search instead for 
Did you mean: 

eglSwapBuffers() can't display content on screen immediately

Jump to solution
1,268 Views
rocwzp
Contributor II

Hello,

I'm using OpenGLES v2.0 and EGL v1.4 to draw graphics on i.MX6 board.

After I finish drawing something on EGL window surface, I call eglSwapBuffers() to display the content and the screen remain blank.

The content could be displayed on screen only after eglSwapBuffers() was called the second time.

Could anyone help me to resolve this issue?

Thanks,

Labels (1)
0 Kudos
1 Solution
182 Views
ChucoChe
NXP Employee
NXP Employee

Any of the GLES2.0 samples in the Sample folder will do. To use double or triple buffer you need to export FB_MULTI_BUFFER with the number of buffers you need.

Michel

View solution in original post

0 Kudos
3 Replies
182 Views
ChucoChe
NXP Employee
NXP Employee

What is the size of your frame buffer, are you using double or triple buffer?

I wonder if the buffers are swapped and your back buffer is still empty.

Do you see the sane behavior with the samples in the GPU SDK?

Michel

0 Kudos
182 Views
rocwzp
Contributor II

The size of my frame buffer is 480 x 272, and I don't know how to use double or triple buffer.

I didn't run any applications in GPU SDK, could you tell me which samples I should run to check this behavior?

Thanks,

0 Kudos
183 Views
ChucoChe
NXP Employee
NXP Employee

Any of the GLES2.0 samples in the Sample folder will do. To use double or triple buffer you need to export FB_MULTI_BUFFER with the number of buffers you need.

Michel

View solution in original post

0 Kudos