connecting two i2c slaves with different voltages to imx6Q

cancel
Showing results for 
Search instead for 
Did you mean: 

connecting two i2c slaves with different voltages to imx6Q

96 Views
srinivasaporam
Contributor II

Hi,

We have got IMX6Q custom board designed based on IMX6Q reference board (Wandboard). Now  we are connecting different i2c slaves with different voltages (one with 1.8 V and another with 3.3V). We have made gpio 1.8 V compatibility (NVCC_GPIO is connected to 1.8V).

Now for 3.3V i2c slave we using some level translator , which makes i2c_SCL (1.8V), and i2c_SDA(1.8V) coming from the processor to 3.3V and given to the i2c slave.

When we are checking connectivity/presence i2c slave by using i2c-tools (i2cdetect), then neither of the i2c slaves are detecting.

Whether i2c with different slaves with different voltages is the real problem or some thing we are missing?????

Labels (4)
0 Kudos
1 Reply

33 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Srinivasa

suggest to check signals with oscilloscope and check level translator

datasheet. Example of usage level translator (TXS0102) can be found

on i.MX53 QSB schematic SCH-27104.

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos